Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 458414 - feature request, rhnpush prompt for credentials first before md5sum check
Summary: feature request, rhnpush prompt for credentials first before md5sum check
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: wes hayutin
URL: na
Whiteboard:
Depends On:
Blocks: space02
TreeView+ depends on / blocked
 
Reported: 2008-08-08 03:38 UTC by wes hayutin
Modified: 2008-08-08 17:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-08 17:33:20 UTC


Attachments (Terms of Use)

Description wes hayutin 2008-08-08 03:38:14 UTC
Description of problem:

This is kind of annoying...  checking the md5 sum for a large directory can take a very long time, and a user will certainly not watch for a user name prompt...

and the following will happen... 

[root@rlx-3-18 Fedora9]# rhnpush --channel=fedora9 --server=https://localhost/APP --dir=/Fedora9/ -vvv
Uploading files from directory /Fedora9/
Connecting to https://localhost/APP
url is https://localhost/PACKAGE-PUSH
Result codes: 200 OK
Computing md5sum and package Info .This may take sometime ...

** 10 minutes later ** 

Red Hat Network username: Red Hat Network username: admin
Red Hat Network password: 

ERROR: unhandled exception occurred: (Timeout Exception).


times out .. have to start over.. boo

Comment 1 wes hayutin 2008-08-08 17:33:20 UTC
after looking at the help for this command realized this is not a bug..
closing..


Note You need to log in before you can comment on or make changes to this bug.