Bug 458415 - Multi-Org, ISE clicking subscriptions link in new org
Multi-Org, ISE clicking subscriptions link in new org
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
wes hayutin
https://rlx-3-18.rhndev.redhat.com/rh...
:
Depends On:
Blocks: space02
  Show dependency treegraph
 
Reported: 2008-08-07 23:44 EDT by wes hayutin
Modified: 2009-09-17 03:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-08-07 23:44:37 EDT
Description of problem:

recreate:
1. create an org
2. click into the org
3. click subscriptions in the org, not the left hand menu..

result ISE

The following exception occurred while executing this request:
GET /rhn/admin/multiorg/OrgSystemSubscriptions.do

Date:8/7/08 11:34:44 PM EDT
Headers:
  host: rlx-3-18.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://rlx-3-18.rhndev.redhat.com/rhn/admin/multiorg/OrgDetails.do?oid=2
  cookie: JSESSIONID=C1DA23321ACCC8C0BA86045CB2F5C134; s_vi=[CS]v1|48754F070000450E-A3A081B00000004[CE]; rh_omni_tc=70160000000H4Ao; rh_omni_itc=70160000000HUrE; pxt-session-cookie=32x3b3eb5debf89d0ef1a95cec906e763d2; s_cc=true; s_sq=%5B%5BB%5D%5D
  Max-Forwards: 10

Request:
Local Name = rlx-3-18.rhndev.redhat.com
Server Name = rlx-3-18.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@9a8d9b[session=StandardSession[C1DA23321ACCC8C0BA86045CB2F5C134]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, org.apache.struts.taglib.html.FORM, virtualization_host_platform, javax.servlet.jsp.jstl.fmt.timeZone.request, virtualization_host, javax.servlet.request.key_size, requestedUri, org, orgSystemSubscriptionsForm, enterprise_entitled, provisioning_entitled, javax.servlet.request.ssl_session, innernavtitle, org.apache.struts.action.MESSAGE, session, monitoring_entitled, __sitemesh__filterapplied, javax.servlet.request.cipher_suite, org.apache.struts.taglib.html.BEAN, org.apache.struts.action.mapping.instance, org.apache.struts.action.MODULE, 


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: javax.servlet.jsp.el.ELException: An error occurred while getting property "upperRange" from an instance of class com.redhat.rhn.frontend.dto.OrgEntitlementDto
	at org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:842)
	at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:779)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspService(Unknown Source)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:98)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:691)
	at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:469)
	at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:403)
	at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)
	at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1085)
	at org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:398)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:107)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.NullPointerException
	at com.redhat.rhn.frontend.dto.OrgEntitlementDto.getUpperRange(OrgEntitlementDto.java:108)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.commons.el.ArraySuffix.evaluate(ArraySuffix.java:314)
	at org.apache.commons.el.ComplexValue.evaluate(ComplexValue.java:145)
	at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:264)
	at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:190)
	at org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(PageContextImpl.java:929)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_bean_message_13(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_c_when_2(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_c_choose_2(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_html_form_0(Unknown Source)
	... 51 more
Comment 1 Mike McCune 2008-08-20 20:26:14 EDT
For some reason the default cert we give to the Spacewalk installer is NOT giving the default (org1) any Monitoring slots.  This is causing some explosion in the code which expects the entitlement to at least be there in the db.
Comment 2 Laszlo Beres 2008-08-21 10:49:08 EDT
As I see our default cert does include slots:

[root@satellite ~]# grep monit /etc/sysconfig/rhn/rhn-entitlement-cert.xml
  <rhn-cert-field name="monitoring-slots">20000</rhn-cert-field>

Despite of this we're getting the original error message.
Comment 3 Mike McCune 2008-08-21 15:28:05 EDT
We were not adding the Monitoring entitlement since Monitoring is disabled by default but in Satellite is enabled by the installer.

Took out the code in rhn-satellite-activate that skips the Monitoring entitlement addition and the above problem goes away.

WORKAROUND:

* Login to Spacewalk GUI
* Click Spacewalk Tools at top
* Click Spacewalk Configuration
* Click Enable Monitoring (you will get an Internal Server Error, but continue)
* Go to your command line on the Spacewalk server and do "rhn-satellite-activate --disconnected"

This should resolve the above issue.
Comment 4 Jason Ganovsky 2008-08-22 00:23:10 EDT
Even after following these steps I still receive the error.
Comment 5 Laszlo Beres 2008-08-22 04:17:29 EDT
Mike, unfortunately it doesn't work for me either.
Comment 6 Jason Ganovsky 2008-08-22 07:33:32 EDT
Is there any way to assign entitlements to a sub org in the meantime, or is the web interface the only way?
Comment 7 Mike McCune 2008-08-22 18:02:39 EDT
Take a peek at:

/etc/rhn/rhn.conf

Does it say:

web.is_monitoring_backend = 1

If not set it to 1.  Then run:

rhn-satellite-activate --disconnected

And try again.  if that doesn't work let me know!
Comment 8 Jason Ganovsky 2008-08-22 22:59:08 EDT
Sorry, didn't work.
Comment 9 Laszlo Beres 2008-08-25 04:46:22 EDT
Neither for me.
Comment 10 Jason Ganovsky 2008-08-27 07:34:08 EDT
Is there anything else we can try or something we can do in the DB manually?
Comment 11 Devan Goodwin 2008-09-05 12:33:27 EDT
Appears to be fixed in spacewalk 0.2, moving to verified but sounds like users are still seeking a solution for spacewalk 0.1 installations.
Comment 12 Jason Ganovsky 2008-09-29 10:28:33 EDT
I upgraded from 0.1 to 0.2 and the problem still exists.  Is there anything we can try?
Comment 13 Devan Goodwin 2008-09-30 12:07:28 EDT
Jason: Could you paste your latest stack trace? Just want to make sure I get the right line number for spacewalk 0.2 source to see if I can tell what might be happening in your db.
Comment 14 Laszlo Beres 2008-12-19 04:09:50 EST
Could we expect any improvements? I've just upgraded to 0.3 and the error above still exists. Here's today's traceback:

The following exception occurred while executing this request:
GET /rhn/admin/multiorg/OrgSystemSubscriptions.do

Date:12/19/08 10:03:56 AM CET
Headers:
  host: satellite.example.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc9 Firefox/3.0.4
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: hu-hu,hu;q=0.8,en-us;q=0.5,en;q=0.3
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-2,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://satellite.example.com/rhn/admin/multiorg/OrgDetails.do?oid=42
  cookie: JSESSIONID=B5D026AF828B6C7719A1606D5667D692; pxt-session-cookie=526xa163b69f1809f8bfd3e96afa2e1229f8
  Max-Forwards: 10

Request:
Local Name = satellite.example.com
Server Name = satellite.example.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@ee479[session=StandardSession[B5D026AF828B6C7719A1606D5667D692]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, org.apache.struts.taglib.html.FORM, virtualization_host_platform, javax.servlet.jsp.jstl.fmt.timeZone.request, virtualization_host, javax.servlet.request.key_size, requestedUri, org, orgSystemSubscriptionsForm, enterprise_entitled, provisioning_entitled, javax.servlet.request.ssl_session, innernavtitle, org.apache.struts.action.MESSAGE, session, monitoring_entitled, __sitemesh__filterapplied, javax.servlet.request.cipher_suite, org.apache.struts.taglib.html.BEAN, org.apache.struts.action.mapping.instance, org.apache.struts.action.MODULE, 


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: javax.servlet.jsp.el.ELException: An error occurred while getting property "upperRange" from an instance of class com.redhat.rhn.frontend.dto.OrgEntitlementDto
	at org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:842)
	at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:779)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspService(Unknown Source)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:98)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:691)
	at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:469)
	at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:403)
	at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)
	at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1085)
	at org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:398)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.NullPointerException
	at com.redhat.rhn.frontend.dto.OrgEntitlementDto.getUpperRange(OrgEntitlementDto.java:108)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.commons.el.ArraySuffix.evaluate(ArraySuffix.java:314)
	at org.apache.commons.el.ComplexValue.evaluate(ComplexValue.java:145)
	at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:264)
	at org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:190)
	at org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(PageContextImpl.java:929)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_bean_005fmessage_005f13(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_c_005fwhen_005f2(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_c_005fchoose_005f2(Unknown Source)
	at org.apache.jsp.WEB_002dINF.pages.admin.multiorg.orgsystemsubs_jsp._jspx_meth_html_005fform_005f0(Unknown Source)
	... 51 more
Comment 15 Miroslav Suchý 2009-09-17 03:00:02 EDT
Spacewalk is released for long time.

Note You need to log in before you can comment on or make changes to this bug.