Bug 45845 - XFree86-S3 3.3.6 fails to install
XFree86-S3 3.3.6 fails to install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 13:01 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-31 05:27:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-25 13:01:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686; Nav)

Description of problem:
I get the following message when I try to upgrade XFree86-S3: (via up2date)
Test install failed because of package conflicts:
file /usr/X11R6/lib/modules/pex5.so from install XFree86-S3-3.3.6-38 
conflicts with file from package XFree86-S3-3.3.6-35

I've also tried to download the file and rpm -Uvh   but this is also
failing because of conflicts.

At current time I'm having a problem with my cursor (it's now a square 1"
block instead of an arrow) and also the graphics are not nice to see. 
Please can you give me an advise how to proceed (or even better what to do
with this square 1" block). My videocard is a Diamond Viper II with the
Savage2000 processor, 32Mb Ram.


How reproducible:
Always

Steps to Reproduce:
1. up2date  then select XFree86-S3
2. or rpm -Uvh XFree86-S3-3.3.6-38.rpm
3.
	

Actual Results:  Nothing it's giving an error

Expected Results:  A newer (better???) version for my XFree

Additional info:
Comment 1 Need Real Name 2001-07-08 10:52:30 EDT
I'm also not able to see any 'video' (mpeg types) anymore, I can hear the sound
but I only see something when I pause the video.
Comment 2 Need Real Name 2001-07-08 10:56:07 EDT
Please give a estimated time when this problem could be solved. I did a total
new install but the problem still occurs.
Comment 3 Mike A. Harris 2001-07-12 23:38:39 EDT
There was a problem with RHN and this update, as well as some other glitches
that somehow managed to get through the cracks.  The problem is
due to some packaging issues that were not discovered until after it was
released, but which are quite large to fix right now.
This will be fixed at some point, but for now, the workaround is to download
the packages via FTP, and upgrade all XFree86 packages at once on a single 
commandline.
Comment 4 Mike A. Harris 2001-07-31 04:37:49 EDT
XFree86-Servers-3.3.6-41 corrects the upgrade problem however it is not
tested.  This package is in our internal tree and will appear in
rawhide in the near future.
Comment 5 Need Real Name 2001-07-31 05:27:34 EDT
Hi,
I can't find the packages you mentioned on the ftp://updates.redhat.com

Please can you give me the path where I can find the package(s)?  Thanks, I've 
you want I can give you my comments of the package(s).


Comment 6 Mike A. Harris 2002-06-19 12:57:08 EDT
Bug hasn't had an indication if the update has worked or not in almost a
year, so I'm assuming the problem is solved and closing the bug as fixed
in Red Hat Linux 7.3.

Note You need to log in before you can comment on or make changes to this bug.