Bug 458459 - server aborts when gnome-session sets keyboard properties
server aborts when gnome-session sets keyboard properties
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-08-08 11:57 EDT by Jeremy Katz
Modified: 2008-09-10 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 12:41:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-08-08 11:57:49 EDT
With gnome's keyboard properties set to make caps lock an additional control, the X server aborts during session init

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x79) [0x80bc109]
1: [0x132400]
2: /usr/bin/Xorg [0x8187751]
3: /usr/bin/Xorg(ProcXkbSetNames+0x35a) [0x8187b4a]
4: /usr/bin/Xorg [0x818a568]
5: /usr/bin/Xorg(Dispatch+0x34f) [0x8085daf]
6: /usr/bin/Xorg(main+0x47d) [0x806b60d]
7: /lib/libc.so.6(__libc_start_main+0xe5) [0x4326e5]
8: /usr/bin/Xorg(FontFileCompleteXLFD+0x225) [0x806a9f1]
Comment 1 Peter Hutterer 2008-08-10 21:00:48 EDT
what layout do you use?
Anything else out of the ordinary except the caps lock remapping?
Comment 2 Jeremy Katz 2008-08-11 01:08:47 EDT
Just a standard us keyboard layout, no other remappings.  And remapping with xmodmap is fine, just going through the gnome keyboard properties leads to the abort
Comment 3 Peter Hutterer 2008-08-11 01:16:23 EDT
Does this happen on login or autologin only?
Does it happen if you type a key before you try to remap it?
Does it crash when you don't have the mapping?

(I can't reproduce it, so there's a bit of guesswork involved)

Can you post the output of setxkbmap -print?
Comment 4 Jeremy Katz 2008-08-11 09:38:21 EDT
Normal login via gdm or startx, early in the session startup before any typing occurs (or, if you remove the remap, when you go to set it again).  And things are fine after I nuked ~/.gconf/desktop/gnome/peripherals/keyboard/

[katzj@aglarond Desktop]$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+inet(evdev)"	};
	xkb_geometry  { include "pc(pc104)"	};
};


It's possible that this is fixed since I hit it and figured out what was going on.  I'll update my laptop again a little later this morning and find out if I still hit it.
Comment 5 Peter Hutterer 2008-08-17 21:35:41 EDT
Jeremy:
Did the update fix the issue?
Comment 6 Jeremy Katz 2008-08-19 10:02:22 EDT
Still happens as of this morning when I tried on the bus
Comment 7 Peter Hutterer 2008-08-28 08:03:48 EDT
Can you reproduce the crash by running setxkbmap -layout us -option "ctrl:nocaps"?

If so, please attach out.xkm after running
setxkbmap -layout us -option "ctrl:nocaps" -print | xkbcomp -xkm - out.xkm

In theory, the output of xkbcomp should be the same as the xkm file gnome uploads.
Comment 8 Jeremy Katz 2008-09-10 12:41:34 EDT
After a rawhide update today, I'm not getting this to happen anymore.

Note You need to log in before you can comment on or make changes to this bug.