Bug 458525 - Adding support for Tango color palette in gnuplot
Adding support for Tango color palette in gnuplot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
http://tango.freedesktop.org/Tango_Ic...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 08:17 EDT by Evert Verhellen
Modified: 2008-08-18 06:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 06:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tango color palette support (diff against 4.3.0, but also works for 4.2.3) (2.09 KB, patch)
2008-08-09 08:17 EDT, Evert Verhellen
no flags Details | Diff

  None (edit)
Description Evert Verhellen 2008-08-09 08:17:37 EDT
Created attachment 313869 [details]
Tango color palette support (diff against 4.3.0, but also works for 4.2.3)

Currently, gnuplot doesn't natively support the Tango color palette. Because of that, using these colors in a plot isn't very practical as one must specify the hexadecimal value such as:

set style line 1 lt rgb "#888a85"
set style line 2 lt rgb "#4e9a06"

Expanding the gnuplot color namespace to include the Tango color palette makes using these colors a lot easier as the .plt stays readable, e.g.:

set style line 1 lt rgb "tango-aluminium-4"
set style line 2 lt rgb "tango-chameleon-3"
Comment 1 Ivana Varekova 2008-08-18 06:13:38 EDT
Hello, I just ask gnuplot upstream whether the patch you have set is acceptable for them (the question is on their mailing list), but they agreed thei will not add it - so  this patch will not be in fedora gnuplot too.
Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.