Bug 458533 - Package description can't be read with dark GTK theme
Package description can't be read with dark GTK theme
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 09:38 EDT by Florent Le Coz
Modified: 2008-08-15 04:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-15 04:19:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Packagekit screenshot showing that it's unreadable (11.16 KB, image/png)
2008-08-09 09:38 EDT, Florent Le Coz
no flags Details
in git master (2.97 KB, patch)
2008-08-11 04:45 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Florent Le Coz 2008-08-09 09:38:23 EDT
Created attachment 313876 [details]
Packagekit screenshot showing that it's unreadable

Description of problem:
With gnome only
I have a Black GTK Theme (see screenshot attached), and when Packagekit shows packages description, it's written in Black so it's impossible for me to read it (I can't even select the text to highlight it).
Appends with information provided by the Updater too.

This color should be the one defined by the GTK theme and not defined to BLACK.


Version-Release number of selected component (if applicable):
gpk-application 0.2.3


How reproducible:
always


Steps to Reproduce:
1.using Gnome, install a dark theme
2.try to read package description with the gnome applet for packagekit
3.fail, because it's black on black (instead of White on black)
  

Actual results:
Can't read the description

Expected results:
Description should be readable.
Comment 1 Richard Hughes 2008-08-11 04:45:45 EDT
Created attachment 313916 [details]
in git master

What about the folowing patch? This seems to fix things for white and black text.
Comment 2 Florent Le Coz 2008-08-13 09:13:29 EDT
Thanks a lot.
If it, indeed, fixes this problem, it's great and should be commited ;-)
Comment 3 Richard Hughes 2008-08-15 04:13:00 EDT
I've updated this to use the theme link colours if available, and if not fall back to this metric. I'll update 0.2.x with this now, so you'll get it on the next Fedora update. Thanks.

Note You need to log in before you can comment on or make changes to this bug.