Bug 458541 - TypeError: unknown key type
TypeError: unknown key type
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 11:16 EDT by John Reiser
Modified: 2013-01-09 20:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-14 08:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file from pungi run (24.67 KB, text/plain)
2008-08-09 11:16 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-08-09 11:16:23 EDT
Created attachment 313880 [details]
log file from pungi run

Description of problem: pungi aborts with runtime error


Version-Release number of selected component (if applicable):
pungi-2.0.3-1.fc10.noarch


How reproducible: always


Steps to Reproduce:
1.pungi -c /usr/share/pungi/rawhide-fedora.ks --destdir=/data/Fedora10 --name Fedora --ver 10
2.
3.
  
Actual results:
Warning: Reusing existing destination directory.
Pungi:INFO: Adding repo rawhide
Pungi:INFO: URL for repo rawhide is ['http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os']
Pungi:INFO: Adding repo rawhide-source
Pungi:INFO: URL for repo rawhide-source is ['http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS']
Pungi:INFO: Getting sacks for arches ['athlon', 'i686', 'i586', 'i486', 'i386', 'noarch', 'src']
rawhide-source                                                                         | 1.9 kB     00:00     
rawhide                                                                                | 2.4 kB     00:00     
Traceback (most recent call last):
  File "/usr/bin/pungi", line 193, in <module>
    main()
  File "/usr/bin/pungi", line 86, in main
    mypungi.getPackageObjects()
  File "/usr/lib/python2.5/site-packages/pypungi/__init__.py", line 350, in getPackageObjects
    self.ayum.tsInfo.addInstall(match)
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 314, in addInstall
    self.add(txmbr)
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 197, in add
    if self.rpmdb.contains(name=pkg_name):
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 345, in contains
    return bool(self.searchNevra(name=name, arch=arch, epoch=epoch, ver=ver, rel=rel))
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 329, in searchNevra
    return self._search(name, epoch, ver, rel, arch)
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 406, in _search
    mi = ts.dbMatch('name', name)
TypeError: unknown key type


Expected results: successful compose of install media


Additional info: will attach /data/Fedora10/logs/i386.log
Comment 1 Jesse Keating 2008-08-12 15:36:40 EDT
This was due to a temporary change to the yum api.  An upcoming yum update will fix this.
Comment 2 Mark McLoughlin 2008-08-14 07:14:07 EDT
I was seeing this, now with latest git yum and pungi, I'm seeing:

  $> pungi -GCB --nosource -c ../buildinstall.ks 
  Warning: Reusing existing destination directory.
  Traceback (most recent call last):
    File "/usr/bin/pungi", line 192, in <module>
      main()
    File "/usr/bin/pungi", line 86, in main
      mypungi._inityum() # initialize the yum object for things that need it
    File "/usr/lib/python2.5/site-packages/pypungi/__init__.py", line 140, in _inityum
      self.ayum.doLoggingSetup(6, 6)
    File "/usr/lib/python2.5/site-packages/pypungi/__init__.py", line 89, in doLoggingSetup
      yum.logging.basicConfig(level=yum.logging.DEBUG, filename=logfile)
  AttributeError: 'module' object has no attribute 'logging'

Re-opening; don't think CLOSED UPSTREAM is appropriate for a blocker bug like this
Comment 3 Jesse Keating 2008-08-14 08:06:15 EDT
that's something more interesting and different.  Can you file that as a different but?  I don't really like the pile-on effect.

Note You need to log in before you can comment on or make changes to this bug.