Bug 458551 - WARNING: at fs/buffer.c:1186 mark_buffer_dirty+0x2c/0x7d()
WARNING: at fs/buffer.c:1186 mark_buffer_dirty+0x2c/0x7d()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 16:44 EDT by Tom London
Modified: 2008-10-10 00:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 00:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-08-09 16:44:16 EDT
Description of problem:

Got this when I unplugged a USB hard drive:

usb 1-1: unregistering device
usb 1-1: usb_disable_device nuking all URBs
usb 1-1: unregistering interface 1-1:1.0
Buffer I/O error on device sdb3, logical block 1547
lost page write due to I/O error on sdb3
journal_bmap: journal block not found at offset 12 on sdb3
Aborting journal on device sdb3.
------------[ cut here ]------------
WARNING: at fs/buffer.c:1186 mark_buffer_dirty+0x2c/0x7d() (Not tainted)
Modules linked in: usb_storage aes_i586 aes_generic bridge stp bnep rfcomm l2cap i915 drm ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi coretemp nf_conntrack_ipv4 ipt_REJECT iptable_filter ip_tables nf_conntrack_netbios_ns nf_conntrack_ipv6 xt_state nf_conntrack xt_tcpudp ip6t_ipv6header ip6t_REJECT ip6table_filter ip6_tables x_tables ipv6 cpufreq_ondemand acpi_cpufreq fuse loop dm_multipath kvm_intel kvm thinkpad_acpi hwmon serio_raw i2c_i801 i2c_core sr_mod cdrom ata_piix ata_generic pata_acpi iTCO_wdt iTCO_vendor_support sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t yenta_socket rsrc_nonstatic hci_usb bluetooth arc4 ecb crypto_blkcipher iwl3945 rfkill mac80211 cfg80211 e1000e snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_hwdep snd soundcore bay video output battery ac ppdev parport_pc parport dm_snapshot dm_zero dm_mirror dm_log dm_mod ahci ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
Pid: 4708, comm: kjournald Not tainted 2.6.27-0.244.rc2.git1.fc10.i686 #1
 [<c0680d89>] ? printk+0x14/0x1b
 [<c042c85d>] warn_on_slowpath+0x4c/0x7d
 [<c04087b6>] ? native_sched_clock+0xb3/0xd3
 [<c0449ec5>] ? trace_hardirqs_off_caller+0x15/0x91
 [<c0449f4c>] ? trace_hardirqs_off+0xb/0xd
 [<c04087b6>] ? native_sched_clock+0xb3/0xd3
 [<c0408633>] ? sched_clock+0x8/0xb
 [<c04494a5>] ? lock_release_holdtime+0x1a/0x115
 [<f90446a7>] ? journal_update_superblock+0x5f/0xaf [jbd]
 [<c04ba61c>] mark_buffer_dirty+0x2c/0x7d
 [<f90446af>] journal_update_superblock+0x67/0xaf [jbd]
 [<f904482a>] __journal_abort_soft+0x90/0x98 [jbd]
 [<c04d7070>] ? disk_name+0x5f/0x6c
 [<f90452df>] journal_bmap+0x58/0x6e [jbd]
 [<c051c205>] ? _raw_spin_unlock+0x74/0x78
 [<f90455a2>] journal_next_log_block+0x66/0x6c [jbd]
 [<f9042247>] journal_commit_transaction+0x6aa/0xc67 [jbd]
 [<c044ac53>] ? trace_hardirqs_on_caller+0xf9/0x11a
 [<c04355b5>] ? try_to_del_timer_sync+0x44/0x4c
 [<f9044f6a>] kjournald+0xc5/0x1fb [jbd]
 [<c043e4de>] ? autoremove_wake_function+0x0/0x38
 [<f9044ea5>] ? kjournald+0x0/0x1fb [jbd]
 [<c043e22c>] kthread+0x40/0x66
 [<c043e1ec>] ? kthread+0x0/0x66
 [<c0404957>] kernel_thread_helper+0x7/0x10
 =======================
---[ end trace a644068e327b5316 ]---

kerneloops'ed here: http://www.kerneloops.org/submitresult.php?number=50002

Version-Release number of selected component (if applicable):
kernel-2.6.27-0.244.rc2.git1.fc10.i686

How reproducible:
Don't know

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-08-23 18:14:00 EDT
Continue to see this with kernel-2.6.27-0.273.rc4.git1.fc10.i686.

Kerneloops'ed here: http://www.kerneloops.org/submitresult.php?number=55628


Aug 23 15:11:26 localhost kernel: lost page write due to I/O error on sdb3
Aug 23 15:11:26 localhost kernel: Buffer I/O error on device sdb3, logical block 1867778
Aug 23 15:11:26 localhost kernel: Buffer I/O error on device sdb3, logical block 3047426
Aug 23 15:11:26 localhost kernel: lost page write due to I/O error on sdb3
Aug 23 15:11:26 localhost hald[2769]: forcibly attempting to lazy unmount /dev/sdb3 as enclosing drive was disconnected
Aug 23 15:11:26 localhost kernel: ------------[ cut here ]------------
Aug 23 15:11:26 localhost kernel: WARNING: at fs/buffer.c:1186 mark_buffer_dirty+0x2c/0x7d() (Not tainted)
Aug 23 15:11:26 localhost kernel: Modules linked in: usb_storage bridge stp bnep rfcomm l2cap bluetooth i915 drm ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi coretemp nf_conntrack_netbios_ns nf_conntrack_ipv4 xt_state nf_conntrack xt_tcpudp ipt_REJECT iptable_filter ip_tables x_tables cpufreq_ondemand acpi_cpufreq fuse loop dm_multipath kvm_intel kvm thinkpad_acpi hwmon serio_raw i2c_i801 i2c_core sr_mod cdrom ata_piix ata_generic pata_acpi iTCO_wdt iTCO_vendor_support sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t yenta_socket rsrc_nonstatic arc4 ecb crypto_blkcipher iwl3945 rfkill mac80211 cfg80211 e1000e snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_hwdep snd soundcore bay video output battery ac ppdev parport_pc parport nsc_ircc irda crc_ccitt dm_snapshot dm_zero dm_mirror dm_log dm_mod ahci ext3 jbd mbcache
Aug 23 15:11:26 localhost kernel: Pid: 4832, comm: umount Not tainted 2.6.27-0.273.rc4.git1.fc10.i686 #1
Aug 23 15:11:26 localhost kernel: [<c0693a31>] ? printk+0x14/0x1b
Aug 23 15:11:26 localhost kernel: [<c042da05>] warn_on_slowpath+0x4c/0x7d
Aug 23 15:11:26 localhost kernel: [<c044b000>] ? add_lock_to_list+0x4f/0x83
Aug 23 15:11:26 localhost kernel: [<c044b0fc>] ? trace_hardirqs_off+0xb/0xd
Aug 23 15:11:26 localhost kernel: [<c040978a>] ? native_sched_clock+0xb3/0xd3
Aug 23 15:11:26 localhost kernel: [<c044b91a>] ? mark_lock+0x1e/0x331
Aug 23 15:11:26 localhost kernel: [<c044b075>] ? trace_hardirqs_off_caller+0x15/0x91
Aug 23 15:11:26 localhost kernel: [<c044b0fc>] ? trace_hardirqs_off+0xb/0xd
Aug 23 15:11:26 localhost kernel: [<c040978a>] ? native_sched_clock+0xb3/0xd3
Aug 23 15:11:26 localhost kernel: [<c0409607>] ? sched_clock+0x8/0xb
Aug 23 15:11:26 localhost kernel: [<c044a69c>] ? lock_release_holdtime+0x30/0x125
Aug 23 15:11:26 localhost kernel: [<f886c6ab>] ? journal_update_superblock+0x5f/0xaf [jbd]
Aug 23 15:11:26 localhost kernel: [<c04bbee8>] mark_buffer_dirty+0x2c/0x7d
Aug 23 15:11:26 localhost kernel: [<f886c6b3>] journal_update_superblock+0x67/0xaf [jbd]
Aug 23 15:11:26 localhost kernel: [<f886b398>] cleanup_journal_tail+0xd0/0xd9 [jbd]
Aug 23 15:11:26 localhost kernel: [<f886b72c>] log_do_checkpoint+0x30b/0x371 [jbd]
Aug 23 15:11:26 localhost kernel: [<c044a5ac>] ? find_usage_backwards+0xb7/0xd8
Aug 23 15:11:26 localhost kernel: [<c044b075>] ? trace_hardirqs_off_caller+0x15/0x91
Aug 23 15:11:26 localhost kernel: [<c044b0fc>] ? trace_hardirqs_off+0xb/0xd
Aug 23 15:11:26 localhost kernel: [<c040978a>] ? native_sched_clock+0xb3/0xd3
Aug 23 15:11:26 localhost kernel: [<c044b91a>] ? mark_lock+0x1e/0x331
Aug 23 15:11:26 localhost kernel: [<c044b075>] ? trace_hardirqs_off_caller+0x15/0x91
Aug 23 15:11:26 localhost kernel: [<c044b0fc>] ? trace_hardirqs_off+0xb/0xd
Aug 23 15:11:26 localhost kernel: [<c040978a>] ? native_sched_clock+0xb3/0xd3
Aug 23 15:11:26 localhost kernel: [<c0409607>] ? sched_clock+0x8/0xb
Aug 23 15:11:26 localhost kernel: [<c044a69c>] ? lock_release_holdtime+0x30/0x125
Aug 23 15:11:26 localhost kernel: [<f886c9d6>] ? journal_destroy+0xf2/0x19e [jbd]
Aug 23 15:11:26 localhost kernel: [<c051dcc1>] ? _raw_spin_unlock+0x74/0x78
Aug 23 15:11:26 localhost kernel: [<f886c9dd>] journal_destroy+0xf9/0x19e [jbd]
Aug 23 15:11:26 localhost kernel: [<c043f6fa>] ? autoremove_wake_function+0x0/0x38
Aug 23 15:11:26 localhost kernel: [<f905de10>] ext3_put_super+0x29/0x199 [ext3]
Aug 23 15:11:26 localhost kernel: [<c049f7f9>] generic_shutdown_super+0x57/0xbe
Aug 23 15:11:26 localhost kernel: [<c04cc5c1>] ? vfs_quota_off+0x0/0x552
Aug 23 15:11:26 localhost kernel: [<c049f874>] kill_block_super+0x14/0x25
Aug 23 15:11:26 localhost kernel: [<c049f93c>] deactivate_super+0x5c/0x6f
Aug 23 15:11:26 localhost kernel: [<c04b1d20>] mntput_no_expire+0xc8/0xfa
Aug 23 15:11:26 localhost kernel: [<c04b2210>] sys_umount+0x296/0x2bb
Aug 23 15:11:26 localhost kernel: [<c0404d02>] syscall_call+0x7/0xb
Aug 23 15:11:26 localhost kernel: [<c069007b>] ? init_centaur+0x118/0x30c
Aug 23 15:11:26 localhost kernel: =======================
Aug 23 15:11:26 localhost kernel: ---[ end trace cba51cedc0eb5099 ]---
Aug 23 15:11:26 localhost hald: unmounted /dev/sdb3 from '/media/_media_disk-1' on behalf of uid 0
Aug 23 15:11:26 localhost hald[2769]: forcibly attempting to lazy unmount /dev/sdb2 as enclosing drive was disconnected
Aug 23 15:11:26 localhost hald: unmounted /dev/sdb2 from '/media/_media_disk' on behalf of uid 0
Aug 23 15:11:26 localhost hald[2769]: forcibly attempting to lazy unmount /dev/sdb1 as enclosing drive was disconnected
Aug 23 15:11:26 localhost ntfs-3g[4791]: Unmounting /dev/sdb1 (IBM_PRELOAD)
Aug 23 15:11:26 localhost hald: unmounted /dev/sdb1 from '/media/IBM_PRELOAD' on behalf of uid 0
Aug 23 15:11:37 localhost kerneloops: Submitted 1 kernel oopses to www.kerneloops.org
Comment 2 Tom London 2008-10-06 12:05:08 EDT
Haven't seen this in quite a while.

Close?

Note You need to log in before you can comment on or make changes to this bug.