Bug 458555 - search line in /etc/resolv.conf contains '\032'
search line in /etc/resolv.conf contains '\032'
Status: CLOSED DUPLICATE of bug 450042
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 18:01 EDT by Levente Farkas
Modified: 2008-10-20 17:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 17:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2008-08-09 18:01:26 EDT
the same problem as in bug: #450042 already in /usr/libexec/nm-dhcp-client.action so it's parse wrongly the conf files. in short *see more detail in bug #450042):
if i set in /etc/dhclient.conf:
supersede domain-search "lfarkas.org. int.bppiac.hu.";
then in /etc/resolv.conf:
search lfarkas.org.\032int.bppiac.hu.
and of course these \032 are not working.
Comment 1 Dan Williams 2008-08-10 22:47:01 EDT
Can you attach some logs from /var/log/messages that include the DHCP results?  It will look something like this:

Aug 10 21:45:46 localhost NetworkManager: <info>  Activation (eth2) Stage 4 of 5 (IP Configure Get) started... 
Aug 10 21:45:46 localhost NetworkManager: <info>    address 192.168.2.100 
Aug 10 21:45:46 localhost NetworkManager: <info>    prefix 24 (255.255.255.0) 
Aug 10 21:45:46 localhost NetworkManager: <info>    gateway 192.168.2.1 
Aug 10 21:45:46 localhost NetworkManager: <info>    nameserver '216.254.95.2' 
Aug 10 21:45:46 localhost NetworkManager: <info>    nameserver '216.231.41.2' 
Aug 10 21:45:46 localhost NetworkManager: <info>  Activation (eth2) Stage 5 of 5 (IP Configure Commit) scheduled...
Comment 2 Levente Farkas 2008-08-11 16:50:27 EDT
Aug 11 22:41:07 sas dhclient: DHCPREQUEST on wlan0 to 192.168.182.1 port 67
Aug 11 22:41:07 sas dhclient: DHCPACK from 192.168.182.1
Aug 11 22:41:07 sas NetworkManager: <info>  DHCP: device wlan0 state changed bound -> renew
Aug 11 22:41:07 sas NetworkManager: <info>    address 192.168.182.2
Aug 11 22:41:07 sas NetworkManager: <info>    netmask 255.255.255.0
Aug 11 22:41:07 sas NetworkManager: <info>    gateway 192.168.182.1
Aug 11 22:41:07 sas NetworkManager: <info>    nameserver '192.168.253.1'
Aug 11 22:41:07 sas NetworkManager: <info>    nameserver '192.168.253.1'
Aug 11 22:41:07 sas NetworkManager: <info>    domain name 'key.chillispot.org'
Aug 11 22:41:07 sas avahi-daemon[2042]: Withdrawing address record for 192.168.182.2 on wlan0.
Aug 11 22:41:07 sas avahi-daemon[2042]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.182.2.
Aug 11 22:41:07 sas avahi-daemon[2042]: Interface wlan0.IPv4 no longer relevant for mDNS.
Aug 11 22:41:07 sas avahi-daemon[2042]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.182.2.
Aug 11 22:41:07 sas avahi-daemon[2042]: New relevant interface wlan0.IPv4 for mDNS.
Aug 11 22:41:07 sas avahi-daemon[2042]: Registering new address record for 192.168.182.2 on wlan0.IPv4.
Aug 11 22:41:07 sas dhclient: bound to 192.168.182.2 -- renewal in 280 seconds.
Aug 11 22:41:08 sas NetworkManager: <info>  Policy set (wlan0) as default device for routing and DNS.
Comment 3 Levente Farkas 2008-08-11 17:02:01 EDT
anyway why don't you simple try it?
----------------------------------
# cat /etc/dhclient-wlan0.conf 
supersede domain-name "lfarkas.org";
supersede domain-name-servers 192.168.0.2,192.168.0.1;
supersede domain-search "lfarkas.org. int.bppiac.hu. bppiac.hu. int.mkk.hu.
mkk.hu. lenux.hu.";
----------------------------------
or anything like this.
Comment 4 Levente Farkas 2008-08-19 18:21:35 EDT
is there any progress?
Comment 5 Levente Farkas 2008-10-04 04:30:54 EDT
it's still not working! so currently NetworkManager not usable:-(
Comment 6 Will Woods 2008-10-20 16:13:19 EDT
Adding search domains using nm-connection-editor (NetworkManager-gnome-0.7.0-0.11.svn4175.fc10.i386) works exactly as expected. No '\032' in resolv.conf, even if I put intentionally-incorrect things in the search like, such as:
"test.redhat.com" "redhat.com test.redhat.com"
Furthermore, NetworkManager does not write dhclient.conf files, so it's not the cause of the problem here. 

The problem is still that syntax error in your dhclient-wlan0.conf:
  supersede domain-search "lfarkas.org. int.bppiac.hu. bppiac.hu. int.mkk.hu.
mkk.hu. lenux.hu."; 
That line is incorrect, and that's the cause of this bug. Fix your dhclient.conf files.

See bug 450042.

*** This bug has been marked as a duplicate of bug 450042 ***
Comment 7 Levente Farkas 2008-10-20 17:23:27 EDT
now turn off on boot interface up and start NetworkManager:
-------------------------------------------
[root@sas ~]# rpm -q NetworkManager
NetworkManager-0.7.0-0.11.svn4022.4.fc9.i386
[root@sas ~]# cat /etc/sysconfig/network-scripts/ifcfg-wlan0 
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Wireless
DEVICE=wlan0
HWADDR=00:14:a5:2c:2e:8b
BOOTPROTO=dhcp
DHCP_HOSTNAME=
DOMAIN=
ONBOOT=no
USERCTL=yes
#IPV6INIT=no
PEERDNS=yes
ESSID=
CHANNEL=
MODE=Managed
#RATE=54M
IPADDR=
NETMASK=
#NM_CONTROLLED=no
[root@sas ~]# cat /etc/resolv.conf
# generated by NetworkManager, do not edit!

domain key.chillispot.org

search key.chillispot.org

nameserver 192.168.253.1
nameserver 192.168.253.1
[root@sas ~]# cat /etc/dhclient-wlan0.conf 
supersede domain-name "lfarkas.org", "int.bppiac.hu", "bppiac.hu", "int.mkk.hu", "mkk.hu", "lenux.hu";
supersede domain-name-servers 192.168.0.2, 192.168.0.1, 192.168.182.1;
[root@sas ~]# dmesg 
(reverse-i-search)`ifco': ifconfig 
[root@sas ~]# ps axufww|grep dhclient|grep -v grep
root      3153  0.0  0.0   2516  1116 ?        S    23:15   0:00  \_ /sbin/dhclient -d -sf /usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-wlan0.pid -lf /var/run/dhclient-wlan0.lease -cf /var/run/nm-dhclient-wlan0.conf wlan0
-------------------------------------------
you see it's not use /etc/dhclient-wlan0.conf!!!!
so is it turn out both of these bug still exists:-(
Comment 8 Will Woods 2008-10-20 17:38:03 EDT
...but there's no \032 in the resolv.conf. Which is what this bug is about. So this bug is CLOSED.

If you want a bug about NetworkManager not respecting /etc/dhclient-wlan0.conf, see bug 446598.

*** This bug has been marked as a duplicate of bug 450042 ***

Note You need to log in before you can comment on or make changes to this bug.