Bug 458565 - avahi-tools rpm should be installed by default
avahi-tools rpm should be installed by default
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 20:56 EDT by Need Real Name
Modified: 2008-10-15 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 22:08:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-08-09 20:56:40 EDT
Description of problem:
Currently the printer setup utility in Fedora 9 can't access Bonjour printers when a standard installation of Fedora 9 is used because the avahi-tools package is not installed (despite the avahi package being installed).

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1: Install Fedora 9 and open the mDNS port in the Firewall.
2. Printing utility from the Admistrative submenu in the System menu of the Gmone Desktop.
3.Click on the NewPrinter button.
  
Actual results:
The local Bonjour printers are not found.

Expected results:
I expected the local Bonjour printers to be found by the New Printer action.

Additional info:
The reason why the Bonjour printers aren't found is that the avahi-browse command is not available from the avahi-tools package. This package should be installed along side avahi (which is already installed by default).
Comment 1 Lennart Poettering 2008-08-11 13:49:26 EDT
I guess the cupps packages need to be fixed to include a dependency on avahi-tools then. Reassigning.
Comment 2 Fedora Update System 2008-10-10 05:13:49 EDT
cups-1.3.9-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/cups-1.3.9-1.fc9
Comment 3 Fedora Update System 2008-10-15 22:08:10 EDT
cups-1.3.9-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.