Bug 458574 - alsa-info behaves very poorly and in a very un-linuxey way.
alsa-info behaves very poorly and in a very un-linuxey way.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 02:48 EDT by Russell Miller
Modified: 2008-09-25 08:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 08:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Miller 2008-08-10 02:48:34 EDT
Description of problem:

> I ran alsa-info.
>
> First it tells me that it's going to automatically upload the results to a
> pastebin site, then it asks me if I want to continue to run the script.
> Strike 1.  It should have defaulted to no, and just ran.  It's just
> outputting info, there's no need to protect me from myself.
>
> Next, I run with the --no-upload option, cursing the damn thing out while I
> do, and then it asks me again, do I want to run the script?  Yeah I want to
> run the script, I *typed the command*.  What is it protecting me from???
>
> So then, it runs, and outputs the data into a file.  Into a *file*?  WTF
> happened to the unix idiom of sending things to stdout unless you
> specifically give it a "-f" option?
>
> I know you guys don't write alsa.  I'm not saying you're responsible for
> this.  What I am saying is that for a long time sysadmin like me, this is
> really a step backwards.  I just want to debug a fricking pulseaudio/alsa
> problem.  Don't protect me from myself when the worst that's going to happen
> is that I get stuff printed to the screen that I don't care about.
>
Version-Release number of selected component (if applicable):

1.0.16-3

How reproducible:

Completely.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Russell Miller 2008-08-10 17:41:23 EDT
Sorry for the tone of this report, I submitted it in a very frustrated mood last night. Please try and ignore the frustrated parts.  The core of it is valid.
Comment 2 Jaroslav Kysela 2008-09-25 08:05:21 EDT
The problems should be fixed in 1.0.17-2 update.

Note You need to log in before you can comment on or make changes to this bug.