Bug 458577 - Change default fuzz to something more sensible
Change default fuzz to something more sensible
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 04:44 EDT by Lubomir Rintel
Modified: 2008-08-12 01:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 12:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2008-08-10 04:44:42 EDT
Description of problem:

Zero fuzz when applying patches makes many routine package maintenance task way more difficult. Rediffing the patch while retaining comments takes time, even if equipped with patchutils.

Our CVS make tooling tries to mitigate that with rediff and patch targets, but they're useless in case your source explodes to something different than %{name}-%{version} or you change a single file with multiple patches. They could surely be fixed/enhanced, but I'm not quite sure rpm should rely on that.

Therefore, please restore the default to 0. I am very sure that number of packages that benefit from zero fuzz is much smaller than ones, that benefit from patch guessing the right place to apply the fuzz, and not rediffing the patch and shuffiling the files around in CVS (due to file name change).
Comment 1 Jindrich Novy 2008-08-11 12:06:03 EDT
You can always use fallback to the original fuzz like:

%patch1 -F3 -p1 -b .backup

so you don't need to rediff patches, simply add -F3 when you are sure what you are doing. The fuzz=0 is the only acceptable default for applying patches from least-surprise POV. Please try to live with it. It pretty much makes sense.
Comment 2 Panu Matilainen 2008-08-12 01:19:08 EDT
Or stick "%define _default_patch_fuzz 2" (2, not 3 is what patch defaults to wrt fuzz) to your specs to avoid having to put it to each %patch command separately.

Note You need to log in before you can comment on or make changes to this bug.