This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 458597 - Bug In initramfs /init detected. Dropping to a shell. Good Luck
Bug In initramfs /init detected. Dropping to a shell. Good Luck
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 14:50 EDT by Bob Agel
Modified: 2009-02-26 13:52 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 13:52:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Agel 2008-08-10 14:50:05 EDT
Description of problem: trying to boot Live CD and/or DVD versions of Fedora 10 Alpha and each fails to boot, quickly ending in a reboot or the words mentioned in Summary.  I've been using every version of Fedora since FC-2 and this is the first failure to boot.  CD's and DVD were checked against sha1sum and burned at slowest speed and data verified prior to attempting to boot. 


Version-Release number of selected component (if applicable):


How reproducible: 


Steps to Reproduce:
1.Insert any DVD/CD and attempt to boot
2.
3.
  
Actual results:
"end_request: I/O error on device sr0, sector 104
"buffer I/O error on device sr0, logical block 13 (line repeats thru 21)
"end_request: I/O error, dev sr0 sector 360
"end_request: I/O error, dev sr0 sector 16840
"buffer I/O error on dev sr0, logical block 4210
"end_request: I/O error, dev sr0, sector 16840
"end_request: I/O error, dev sr0, sector 16844
"bug in initramfs /init detected. Dropping to a shell.  Good Luck"


Expected results:
A boot would have been nice.


Additional info: on DVD, media test fails but no additional info, simply a fail and reboot.  As mentioned, sha1sum/data verification was fine prior to attempt; other distros continue to be installed and booted on DVD or Live CDs without error.  Burns were with good quality media and K3b.
Comment 1 Daniel Malmgren 2008-08-11 06:53:21 EDT
This clearly has nothing with initng to do. Not quite sure where to put it though, I don't know anything about livecd stuff. Guess I'll class it as sysvinit...
Comment 2 Will Woods 2008-11-06 15:27:28 EST
This is almost certainly a bad burn, or your drive going bad.

Try a different brand of media, or make a LiveUSB stick instead.
Comment 3 Chris Pemberton 2008-11-06 16:30:47 EST
I have a similar error with F10-PR-x86_64-Live.iso.
The downloaded iso file's sha1sum checks out fine.
Twice I burned the iso to CD, and each time the boot process stalled with the exact same sector error (indeed, the identical sector number as well):

end_request: I/O error, dev sr0, sector 1402052
(line repeated)
(line repeated)
... 

So, either my burner made two identical bad burns, or something could be wrong with the iso file.

I am now trying to write the CD at the lowest possible speed for my writer, 16x, to see if that could be the problem.
Comment 4 Chris Pemberton 2008-11-06 16:51:01 EST
It failed the same after writing at 16x as well.  This time I pressed the Esc key to see what was going on.  The full error I am getting is:

end_request: I/O error, dev sr0, sector 1402052
Buffer I/0 error on device sr0, logical block 350515
(repeat both lines)
(repeat both lines)
...

I have no other 64-bit machine to test on.  This machine has no problem writing or booting any other iso (archlinux, openbsd, ubuntu, opensolaris) and I'm writing the iso from a stack of known good blank media.
Comment 5 Joshua Klar 2008-11-07 17:52:19 EST
From my Fedora Forums post


I am typing this from F10 KDE Preview as we speak. For me it was odd, with my USB zip drive in it Verified as FAIL at like 99% done and said dropping to a shell. With it out, it boots (dog slow) but throws a hissy fit of
Quote:
After the udevadm settle timeout, events queue contains
850: /devices/pci 0000:00/0000:00:02:5/host/target 1:0:0/1:0:0:0/block 5r0

And, in Plymouth's nasty bars (nvidia) it kept interrupting with
Quote:
end_request I/O error dev sr0 sector 1329592

Will duplicate this in Fedora Bugzilla, see if anything here is valuable... PS i think the zip drive had nothing to do with it... this was a 4th burn, 1st on this iso, i had an iso before that flunked at about 20%
Comment 6 cornel panceac 2008-11-14 06:50:23 EST
same error ("bug in intiramfs /init detected. ....") on thinkpad x40, after several times f10 i686 preview livecd just crashed before starting gdm. check ok, boot device is usb cdrom drive. command line is: <without rhgb quiet> vesa nomodesetting
i don't see the i/o errors.
Comment 7 cornel panceac 2008-11-14 07:24:34 EST
i believe in my case the problem was the "vesa" bootparam. once i remove it, the livecd works till the original breakpoint, before starting gdm.
Comment 8 Bug Zapper 2008-11-25 21:43:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 ^mp3axe^ 2008-11-29 04:54:21 EST
I have respun the livecd from a Fedora 10 VM appliance.  The problem persists.

For me, however the preceding message to the "initramfs /init" message is some error about "mount wrong fs type in /dev/loop2".

I have this problem in 3 separate machines.
- Dell Inspiron 530 (desktop)
  - Intel P30 based board
  - 1 SATA optical drive
  - ATI based graphics

- Dell Latitude D620 (laptop)
  - Intel 965? based board
  - 1 ATAPI optical drive
  - NVidia based graphics

- Dell Latitude E6400 (laptop
  - Intel Mobile 45 series board ?
  - 1 SATA optical drive
  - NVidia based graphics

This problem occurs with both the 11/20 x64 F10 live CD downloadable from the mirrors as well as my own respun image using "/usr/share/spin-kickstarts/fedora-livecd-desktop-en-US.ks" from the "spin-kickstarts" package.

Does anyone know of a workaround in the meantime?
Comment 10 Bob Agel 2008-11-29 06:37:54 EST
Just a follow-up on my initial bug report. The DVD-RW drive involved has progressively thrown more and more errors and is possibly the cause of the mess.  I'm in the process of replacing it.
Comment 11 Jens Petersen 2009-02-04 01:02:04 EST
(In reply to comment #9)
> I have respun the livecd from a Fedora 10 VM appliance.  The problem persists.
> For me, however the preceding message to the "initramfs /init" message is some
> error about "mount wrong fs type in /dev/loop2".

Same for me.

F10-i686-Live.iso boots fine for me,
but not a local respin with updates: F10-Live-i686-20090203T2009.iso.
Comment 12 Jens Petersen 2009-02-04 03:03:44 EST
> but not a local respin with updates: F10-Live-i686-20090203T2009.iso.

Ah nevermind, escaping out of plymouth I see my problem is actually due to a squashfs version mismatch...

squashfs-tools-4.0 (rawhide) is too new for F10 kernel (squashfs-3.4) and f9 squashfs-tools too old I guess.
Comment 13 leigh scott 2009-02-04 03:58:27 EST
(In reply to comment #12)
> > but not a local respin with updates: F10-Live-i686-20090203T2009.iso.
> 
> Ah nevermind, escaping out of plymouth I see my problem is actually due to a
> squashfs version mismatch...
> 
> squashfs-tools-4.0 (rawhide) is too new for F10 kernel (squashfs-3.4) and f9
> squashfs-tools too old I guess.




squashfs-tools-4.0 works OK with the new F10 2.6.29 kernels
Comment 14 Joachim Frieben 2009-02-17 06:44:24 EST
How about updating squashfs-tools in F10? Creating a live CD from the "rawhide" succeeds but the media is not bootable because of the argument put forward in comment #12.
I have locally rebuilt squashfs-tools-4.0-0.20090125.x86_64, and after installing it, the newly created live ISO image is bootable. Moreover, squashfs-tools-4.0-0.20090125.x86_64 is only required by livecd-tools. There should thus not be any impact on the rest of F10.
Comment 15 Joshua Covington 2009-02-24 06:33:18 EST
I got the same here:

"Cannot find Root filesystem. Bug in intramfs/init detected. Dropping to a
shell. Good luck!"  I tried a custom livecd with rawhide as of 23.02.2009 and got the same behaviour. The plymouth starts and the modesetting works, when using debug at startup the kernel boots and detects most of my hardware and then comes this error message.

I then made a custom F10 livecd with the 2.6.29.rc kernel and got the same error. I changed the kernel to 2.6.27 (current for fc10) and rebuild the livecd with same components as before (they were cached at the first build) and everything worked just fine. This makes me think that the error comes from the kernel itself, but there are no kernel-oops at startup and when building the livecd the kernel installs without errors.
Comment 16 Joshua Covington 2009-02-24 06:37:40 EST
(In reply to comment #13)
> 
> squashfs-tools-4.0 works OK with the new F10 2.6.29 kernels

I've used the lastest quashfs-tools-4.0-0.20090125.x86_64 in my livecd and still get this error.
Comment 17 Hans de Goede 2009-02-25 05:07:12 EST
Given that this is a problem with livecd's I'm re-assigning this to Jeremy.
Comment 18 Joshua Covington 2009-02-25 20:37:54 EST
It turns out that mkinitrd is causing the problem. After updating to the latest version in koji the new kernel 2.6.29.rc works fine. Maybe the current f10 version isn't suitable for the -29.rc kernel.

Can someone else verify this?
Comment 19 Jeremy Katz 2009-02-26 13:52:51 EST
If you're using a 2.6.29 kernel for your images, yes, you need to have the newer squashfs-tools installed as well.  When the kernel is pushed to final, squashfs-tools will go with it

Note You need to log in before you can comment on or make changes to this bug.