Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 458599 - SELinux stops system-config-services
Summary: SELinux stops system-config-services
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-10 19:36 UTC by Andreas Tunek
Modified: 2008-09-09 17:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-08 19:59:56 UTC
Type: ---


Attachments (Terms of Use)

Description Andreas Tunek 2008-08-10 19:36:58 UTC
Description of problem:
SELinux is preventing the dbus-daemon-lau (system_dbusd_t) from executing ./system-config-services-mechanism.py. 

Version-Release number of selected component (if applicable):
selinux-policy-3.5.1-4.fc10

How reproducible:
Always.

Steps to Reproduce:
1. Try to start system-config-services
2. ??
3. Profit!! (system-config-services does not start, instead you get a selinux denial.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Walsh 2008-08-11 20:53:34 UTC
Fixed in selinux-policy-3.5.2-2.fc10.noarch

Comment 2 Nikolay Vladimirov 2008-08-12 09:47:37 UTC
Why is this bug closed? The last 4 builds of selinux-policy are with status "failed". This is NOT fixed in rawhide. 
There is no point in reopening the bug since it will be closed after a successful build. Just a note to all that are still having the same problem.

Comment 3 Andreas Tunek 2008-08-30 20:07:48 UTC
This bug is still present in selinux-policy.noarch 3.5.5-1.fc10

Comment 4 Daniel Walsh 2008-09-02 20:29:21 UTC
Does 
#restorecon  -v /usr/share/system-config-services/system-config-services-mechanism.py

Fix the file context?

Comment 5 Andreas Tunek 2008-09-09 17:52:03 UTC
Yeah, now it works for me to. Thanks for all the help.


Note You need to log in before you can comment on or make changes to this bug.