Bug 458604 - Document GFS "withdraw" function in GFS manual
Document GFS "withdraw" function in GFS manual
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 16:37 EDT by Steven J. Levine
Modified: 2009-09-03 12:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 12:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2008-08-10 16:37:33 EDT
Description of problem:
I'm looking over all my open documentation issues as RHEL 5.3 deadlines approach, and this is an issue that's been filed as an RT (RT 473), but I think it probably should be a bug instead, for ease of tracking.


These are the key messages for this bug:

Mon Aug 13 18:22:09 2007  	mhideo@redhat.com - Correspondence added 	  	 
> [pkennedy@redhat.com - Wed Jan 25 11:48:13 2006]:
>
> Publish a KB article describing the actions of the GFS "withdraw" function.
> Related to Bugzilla 177702.
>

Status:
Q3 Activity

Target:
GFS Admin Guide

---------

Tue Nov 27 18:27:30 2007  	pkennedy@redhat.com - Comments added 	  	 

Steven,

I'm transferring this RT to you. Originally, we were looking at writing a KB article. At this point, we may as well consider it for the GFS books instead.

Paul

------------

Mon Apr 07 10:36:19 2008  	slevine@redhat.com - Comments added 
	  	 
I sent this email to Ryan Ohara on 4/7/08:

Ryan:

I'm looking through my assigned bugs and I came across RT 473, which notes that we should look at documenting the GFS "withdraw" function in the GFS manual. (Originally the plans were that this would be a KB article). Paul noted that this relates to Bugzilla 177702.

I've looked over Bugzilla 177702. It looks as though you closed that bug because it concerned md multipathing, which we no longer support for GFS. You noted this, in the bug:

---
Prior to having the withdraw capability, when an I/O error occured the kernel
would panic and thus be fenced. The other nodes can then process with recovery.

Now when an I/O error occurs, the node will withdraw from the cluster. This
stops I/O, waits for pending I/O to error out, and leaves the lockspace. Then,
usually, you can unmount the filesystem. A reboot of the node is recommended
regardless of success/failure of unmount. The advantage of withdraw is that you
can stop any services, application, etc. manually before reboot.

----

Is that the information that the GFS manual should include? If so, is that the extent of what we need to add to the GFS manual, or is there more? In other words, what was the proposed DB article slated to include?

I know this is probably stretching the memory a bit, but do you have any pointers here that I might check out to get this info into the next revision of the GFS manual?

Thanks,

-Steven

---------

I never heard back from Ryan, so I'm re-pinging here.
Comment 1 Steven J. Levine 2009-06-26 12:40:09 EDT
With the help of Bob Peterson, I wrote up a new section for the GFS2 document on the GFS2 withdraw function. I sent that document out for general review on June 25 with a two-week review period, and I highlighted this new section in the cover note. After incorporating review comments, I will add this section to the GFS document as well, and both the updated documents are on track for inclusion in the RHEL 5.4 release.
Comment 2 Steven J. Levine 2009-09-03 12:04:11 EDT
With the release of RHEL 5.4 I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.