Bug 458616 - KDE 4.1.0: "switch user" simply locks the current user out, exactly like "lock".
KDE 4.1.0: "switch user" simply locks the current user out, exactly like "lock".
Status: CLOSED DUPLICATE of bug 560511
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 20:09 EDT by Martin Köbele
Modified: 2010-10-27 12:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 08:09:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 166985 None None None Never

  None (edit)
Description Martin Köbele 2008-08-10 20:09:50 EDT
Description of problem:
"Switch user" simply locks the current user out, exactly like "lock". 
It is supposed to show a dialog where you can start a new session for a new user but keep the current one.

Version-Release number of selected component (if applicable):
4.1.0

How reproducible:


Steps to Reproduce:
1. Klick on the "K" in your taskbar 
2. and then "Leave" (or is it "system"?, the widget where there is "Lock", "shutdown", "Restart" etc.
3. and then "Switch User". 
  
Actual results:
"Switch user" simply locks the current user out, exactly like "lock". 

Expected results:
It is supposed to show a dialog where you can start a new session for a new user but keep the current one.

Additional info:
Regarding aseigo, it is supposed to work
https://bugs.kde.org/show_bug.cgi?id=166985
Comment 1 Martin Köbele 2008-08-10 20:33:39 EDT
it actually works after deleting ~/.kde
Comment 2 Martin Köbele 2008-08-10 20:43:08 EDT
damn, I closed it too quickly.....

The only improvement I experienced after deleting ~/.kde was that I actually get a dialog explaining me the details of user switching (F7,F8 etc).
But after proceeding, the screen goes black and when I move my mouse, I get the "unlock" dialog. No widget for starting a new session appears.

I wish I could reopen this bug.
Comment 3 Rex Dieter 2008-08-11 00:41:51 EDT
reopened on request.  

Unfortunately, I cannot reproduce this (works here for me).
Comment 4 Rex Dieter 2008-08-11 00:42:33 EDT
One question though, did this ever work for you?  If so, when did it break?
Comment 5 Martin Köbele 2008-08-11 06:29:49 EDT
(In reply to comment #4)
> One question though, did this ever work for you?  If so, when did it break?

It used to work in KDE 3.5.9. It was officially broken in KDE 4.0.x, x < 5, I believe.

Are there any logfiles which could contain any additional information?
Comment 6 Rex Dieter 2008-08-11 06:47:10 EDT
thx, I was mostly concerned if this was a 4.0->4.1 regression or not.

So, next question, how are you starting kde?  Are you using kdm?  (hint: you need to use kdm for this to have any chance of working).
Comment 7 Martin Köbele 2008-08-11 06:52:13 EDT
ugh, doesn't fedora give me gdm by default? This might be it!
How/Where do I change whether gdm or kdm is used?
Comment 8 Rex Dieter 2008-08-11 07:11:17 EDT
Unfortunately, it all depends on how you installed fedora/kde.

If you installed from the KDE live image, everything should "just work" and use kdm.  Otherwise, yeah, you end up with gdm (which isn't compatible here).

to be sure, add to /etc/sysconfig/desktop (or create if not already present),
DISPLAYMANAGER=KDE
and reboot (note: simply restarting X is insufficient).
Comment 9 Martin Köbele 2008-08-11 07:24:39 EDT
yes, thank you. I have just found /etc/X11/prefdm and noticed that it used the fallback where it starts gdm first. I had commented that line out, but creating the desktop file in sysconfig is the proper way to do it, and that's what I have now.

It works beautifully now!

Thank you!
You can close this bug.
Comment 10 Martin Köbele 2008-08-11 07:25:19 EDT
no reboot necessary..

# init 3
followed by
# init 5

is enough
Comment 11 Kevin Kofler 2010-10-27 12:57:46 EDT

*** This bug has been marked as a duplicate of bug 560511 ***

Note You need to log in before you can comment on or make changes to this bug.