Bug 458648 - %configure sets --target
%configure sets --target
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 516389 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 06:44 EDT by Stepan Kasal
Modified: 2010-02-02 05:01 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 05:01:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (574 bytes, patch)
2008-08-11 06:44 EDT, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Stepan Kasal 2008-08-11 06:44:50 EDT
Created attachment 313947 [details]
proposed patch

Macro %configure contains --target=%{_target_platform}.
It should be better removed.

Let me remind that in GNU-style configure scripts, --target means "the plafrom targeted by the tool just built".  For example, if you are building a cross-tool, which is about to run on i386 and generate code for arm, then --target=arm-something.
In most cases, this is not needed, because the rpm package does not contain any cross-building tool.
And in the case that the package is a cross-building tool, this --target definition does not help either, because of the ambivalent tradition of _target* macros in rpm.

Moreover, note that %{_target_platform} is used, not %{_target}, so it can easily happen that
a) it is not right or
b) it is a string different from %{_host} which, though right, can easily confuse the %configure script.

It is best to remove --target from %configure.
(The spec files for cross-build tools can then easily add the right --target.)
Comment 1 Bug Zapper 2008-11-25 21:44:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Panu Matilainen 2009-08-13 09:49:58 EDT
Fixed upstream now, but on Fedora redhat-rpm-config overrides the default %configure so the change needs to be done there for it to make any difference.
Comment 3 Panu Matilainen 2009-08-13 09:50:20 EDT
*** Bug 516389 has been marked as a duplicate of this bug. ***
Comment 4 Bug Zapper 2009-11-16 03:11:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Panu Matilainen 2010-02-02 05:01:38 EST
Fixed in rawhide as of redhat-rpm-config-9.1.0.

Note You need to log in before you can comment on or make changes to this bug.