Bug 458659 - system-config-printer does not start up correctly
system-config-printer does not start up correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 08:16 EDT by Joachim Frieben
Modified: 2008-08-11 12:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 08:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-08-11 08:16:53 EDT
Description of problem:
For a current "rawhide" system, system-config-printer cannot be used to configure printers. When launching it from the system menu, a button appears on the lower panel but quickly disappears. No application window gets opened.

Version-Release number of selected component (if applicable):
system-config-printer-1.0.4-1.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open 'System > Administration > Printing'.
  
Actual results:
A button related to s-c-p appears briefly at the bottom panel and quickly disappears again.

Expected results:
Application window is opened and responsive to user input.

Additional info:
In .xsession-errors, one reads the following traceback:

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py",
    line 31, in <module> import gtk.glade
  File "/usr/lib64/python2.5/site-packages/gtk-2.0/gtk/__init__.py",
    line 48, in <module> from gtk import _gtk
  ImportError: /usr/lib64/libfontconfig.so.1: undefined symbol:
    FT_Select_Size

When launched by root from the shell after executing 'su root', then a window is opened but no content is ever rendered until it gets killed by the user. Moreover, it does not respond to ctrl-c forcing the user to kill the terminal window in order to terminate s-c-p. The following message is spawned to the shell:
(system-config-printer.py:3616): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Comment 1 Joachim Frieben 2008-08-11 08:27:03 EDT
Closing as NOTABUG: after removing a local copy of libfreetype.so.6.3.8 [used instead of system library libfreetype.so.6.3.17 in order to work around bug 198082], s-c-p starts correctly from the system menu.
Comment 2 Tim Waugh 2008-08-11 08:30:24 EDT
Works for me with fontconfig-2.6.0-2.fc10 and gtk2-2.13.6-2.fc10.

What versions do you have?

(Changing component as this is not a system-config-printer bug.)
Comment 3 Joachim Frieben 2008-08-11 11:57:03 EDT
Installed packages are:

 fontconfig-2.6.0-2.fc10.x86_64
 gtk2-2.13.6-2.fc10.x86_64

I recall that this issue only occurs when libfreetype.so.6.3.8 (as opposed to current libfreetype.so.6.3.17) is in the library search path. I am used to recompiling the FC5 source RPM for every Fedora release because rendering quality of Luxi (default system font family prior to FC6) and Verdana fonts has deteriorated as of freetype >= 2.2.x.
Comment 4 Joachim Frieben 2008-08-11 12:09:52 EDT
FT_Select_Size is a new function type introduced in FreeType 2.2 and thus missing in FreeType 2.1.10 [FC5] which explains the complaint. This had to happen one day ..

Note You need to log in before you can comment on or make changes to this bug.