Bug 458662 - rpc.quotad is not shut down upon '/etc/init.d/nfs stop'
rpc.quotad is not shut down upon '/etc/init.d/nfs stop'
Status: CLOSED DUPLICATE of bug 470483
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 08:47 EDT by martijn
Modified: 2008-11-24 11:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 09:14:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description martijn 2008-08-11 08:47:42 EDT
Description of problem:
rpc.quotad is not shut down upon '/etc/init.d/nfs stop'

Version-Release number of selected component (if applicable):

1.0.9-33.el5

How reproducible:
  /etc/init.d/nfs start
  /etc/init.d/nfs stop
  rpcinfo -p | grep rquotad

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
    100011    1   udp    889  rquotad
    100011    2   udp    889  rquotad
    100011    1   tcp    892  rquotad
    100011    2   tcp    892  rquotad


Expected results:
  <empty>

Additional info:
Normally, performing an '/etc/init.d/nfs restart' does not produce any warnings that the rquotad is still running. However, if you set a line like this in /etc/sysconfig/nfs:
  RQUOTAD_PORT=4003
you will see the following message upon '/etc/init.d/nfs restart':
  Starting NFS quotas: rpc.rquotad: Cannot bind to given address: Address already in use

Problem can be fixed by adding these lines to the stop) case:
        # Remote quota server
        [ -z "$RQUOTAD" ] && RQUOTAD=`type -path rpc.rquotad`

(For some reason these were moved from top-level to within the start case in the upgrade of 5.1 to 5.2.
Comment 1 Gianluca Cecchi 2008-08-19 05:32:28 EDT
The bug is still present in latest version nfs-utils-1.0.9-35z.el5_2 with wich I updated an rh el 5.2 x86 system.
The annoying thing is that current F9 x86_64 which has nfs-utils version 1.1.2-6.fc9 is correct as the part

# Remote quota server
[ -z "$RQUOTAD" ] && RQUOTAD=`type -path rpc.rquotad`

was moved at the very beginning, out of start/stop/ecc. sections.

I'm configuring a server with  drbd/nfs/ha and moved the /var/lib/nfs dir under drbd file system and heartbeat is not able to cleanly unmount the resource because rquotad has in use  /var/lib/nfs/rpc_pipefs
Comment 2 Gianluca Cecchi 2008-08-19 06:04:34 EDT
With the term "The annoying thing is..." I didn't want to hurt anyone: miswritten.
Sorry.
Probably the new version 1.1 of nfs-utils already incorporated the redesign of the start/stop script.

Gianluca
Comment 3 Bryn M. Reeves 2008-11-13 11:50:03 EST
In reply to comment #2, it seems like the intent was to make this match what is now done in f9 & rawhide - have you tried moving the line that checks & sets RQUOTAD to the top of the script as it is in f9?
Comment 4 Steve Dickson 2008-11-24 09:14:29 EST

*** This bug has been marked as a duplicate of bug 470483 ***
Comment 5 Gianluca Cecchi 2008-11-24 11:36:04 EST
As I wrote in the first post, I solved putting it in the stop) section, just before the if statement containing 
killproc rpc.rquotad

Same effect putting it at the beggining of the script itself.

BTW: strange to see this bug marked as a duplicated of an access denied bug...

Note You need to log in before you can comment on or make changes to this bug.