Bug 458667 - "MIME Types" menu option does not work
"MIME Types" menu option does not work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-commander (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 10:11 EDT by Daniel Novotny
Modified: 2008-09-10 03:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 02:51:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 347852 None None None Never

  None (edit)
Description Daniel Novotny 2008-08-11 10:11:44 EDT
Description of problem:
When I want to change the default application that will run after double-clicking a file, I click Setting --- MIME Types, but nothing happens

The terminal output is:

  gnome-file-types-properties: command not found

so the program relies on a configuration utility, which is no longer present.

IMHO if there is no such utility in recent GNOME, we should tell this to GNOME upstream. If there is, we should find and use it. 

Version-Release number of selected component (if applicable):
1.2.7-1.fc9

How reproducible:
100% reproducible

Steps to Reproduce:
1. run GNOME commander
2. click "MIME types" in the "Settings" menu
3.
  
Actual results:
nothing happens

Expected results:
a MIME types configuration utility should appear

Additional info:
Comment 1 Mamoru TASAKA 2008-08-11 10:40:20 EDT
This issue is already reported upstream, however the upstream doesn't seem to
have the intention to fix this issue.
Since gnome-file-types-properties exists only GNOME < 2.8 era, if you want I
will try to hide that menu ?
Comment 2 Daniel Novotny 2008-08-11 11:00:24 EDT
it's sad, that upstream does not want to fix this, because this would improve GNOME usability a lot, IMHO.

Hiding the option is one thing you can do, but I have another idea: try to run gnome-file-types-properties, if it is present in the system. If it is not present, show a dialog box, saying that the feature is not supported. 

Do you think the -hypothetical- dialog box should point to some place, where people can complain, that this feature is missing? Or is it too "aggressive" approach?
Comment 3 Mamoru TASAKA 2008-08-11 12:29:36 EDT
(In reply to comment #2)
> but I have another idea: try to run
> gnome-file-types-properties, if it is present in the system. If it is not
> present, show a dialog box, saying that the feature is not supported. 
> 
> Do you think the -hypothetical- dialog box should point to some place, where
> people can complain, that this feature is missing? Or is it too "aggressive"
> approach?

Honestly saying I don't think such approarch is really needed.

BTW currently I am looking at
http://lists.gnu.org/archive/html/gcmd-devel/2007-11/msg00076.html
and examining what I can do for this.
Comment 4 Mamoru TASAKA 2008-08-11 13:41:56 EDT
Hello, again:
Would you try this and tell me how you think of this?

http://kojipkgs.fedoraproject.org/packages/gnome-commander/1.2.7/3.fc9/
Comment 5 Daniel Novotny 2008-08-12 03:42:13 EDT
wow, this looks very, very nice, thanks a lot

but there is one original need I wanted to satisfy with MIME types editing: I installed both Vim and Emacs and then when I double-click a C file in Gnome Commander, Emacs is run, because I installed it later. To open it in Vim, I need to right-click the file and select "open with". The same holds for other types of files: where there are more viewers/editors, it would be nice to be able to set the default one - 

I think this can be done by editing /usr/share/applications/mimeinfo.cache - this file is -afaik- changed every time you install a new application, so it is not wise to make a local copy in the home directory, it will be enough just to add a button to edit it... or just a note to the user that they can do it themselves (in the label of the window)

thanks and cheers, I think this one other simple change will totally fix the issue...
Comment 6 Mamoru TASAKA 2008-08-12 07:05:04 EDT
Well, it may be that currently I don't understand what you mean correctly,
however:

(In reply to comment #5)
> I think this can be done by editing /usr/share/applications/mimeinfo.cache -
> this file is -afaik- changed every time you install a new application, so it is
> not wise to make a local copy in the home directory, it will be enough just to
> add a button to edit it... or just a note to the user that they can do it
> themselves (in the label of the window)

But /usr/share/applications/mimeinfo.cache is not non-sysadmin-user editable.
What do you really suggest?
Comment 7 Daniel Novotny 2008-08-12 09:40:27 EDT
The problem is that one MIME type can be associated to more than one application. One is the default which runs when you double-click. I was looking for a way to change this default -this was, in fact, my first motivation for opening this bug-  is there anything a non-admin-user can do?

If not, your solution is complete.
Comment 8 Mamoru TASAKA 2008-08-12 10:37:38 EDT
(In reply to comment #7)
> The problem is that one MIME type can be associated to more than one
> application. One is the default which runs when you double-click. I was looking
> for a way to change this default -this was, in fact, my first motivation for
> opening this bug-  is there anything a non-admin-user can do?

What I can say for now is that "I don't know". Perhaps the fact that GNOME doesn't
seem to provide such tools shows that there is not a easy way for non-admin user?

For now I regard my last change as the "solution" for this bug. If you got another
idea please let me know it.
Comment 9 Daniel Novotny 2008-08-12 11:03:04 EDT
Yes, it is a solution. Thanks a lot for your effort.
Comment 10 Mamoru TASAKA 2008-08-12 11:39:04 EDT
Okay, thank you!
Comment 11 Fedora Update System 2008-08-12 11:46:07 EDT
gnome-commander-1.2.7-4.fc9 has been submitted as an update for Fedora 9
Comment 12 Fedora Update System 2008-08-12 11:46:53 EDT
gnome-commander-1.2.7-4.fc8 has been submitted as an update for Fedora 8
Comment 13 Fedora Update System 2008-09-10 02:51:10 EDT
gnome-commander-1.2.7-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-09-10 03:03:10 EDT
gnome-commander-1.2.7-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.