Bug 458673 - Expectation of running hts clean before hts plan not documented
Expectation of running hts clean before hts plan not documented
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 10:23 EDT by Rick Hester
Modified: 2014-03-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 11:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Hester 2008-08-11 10:23:31 EDT
Description of problem:
(In reply to comment #9)

When I added a NIC to the system after having previously ran hts plan,
running hts plan again did not add the new card to the plan.  When I reported
this it was suggested that I neede to run hts clean before running hts plan.

The hts documentation did not indicate that
it is a requirement to run hts clean.  The output from hts plan implies 
that a new plan has been created, so there are no implications that another
step is needed.   So the documentation should be updated to indicate this
requirement.  

The documentation on hts clean
indicates that "The Clean command removes all HTS log files, test results, and
the test plan." So, the average user hts, would not be inclined to run this
command because it removes all test results. In fact, if tests have already
been run with test results already established, running hts clean would not
be in the users' best interest.  A much better approach to this problem 
would be to fix hts plan so that it copies the previous plan to a backup
location and then completely builds a new plan file.

Version-Release number of selected component (if applicable):
hts-5.2-16

How reproducible:
I've only run this once on the R16 version, but have noticed this behavior
in the past.

Steps to Reproduce:
1. Run hts plan on an existing server configuration
2. Add another network interface to the system
3. Run hts plan again
  
Actual results:
The new card is not added to the plan.

Expected results:
The new card to be added to the plan.

Additional info:
Comment 3 Greg Nichols 2009-01-29 11:49:31 EST
New man page addresses this issue

Note You need to log in before you can comment on or make changes to this bug.