Bug 458720 - gpart missing for x86_64
gpart missing for x86_64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Dennis Gregorovic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 17:00 EDT by Jason Bradley Nance
Modified: 2008-09-05 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 12:35:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Bradley Nance 2008-08-11 17:00:32 EDT
'gpart' doesn't seem to exist for the x86_64 build of RHEL5 (not even as an i386 rpm).
Comment 1 David Cantrell 2008-08-11 18:49:31 EDT
The package has:

ExclusiveArch: i386

In its spec file.  There should be an i386 one available.  I just checked and you should be able to install gpart-0.1h-3.1.i386.rpm.  That package is in the x86_64 tree for RHEL 5.2.
Comment 2 Jason Bradley Nance 2008-08-11 18:56:12 EDT
It's not on the 5.2 isos I have (from RHN):

rhel-5.2-server-x86_64-dvd.iso
rhel-5.2-server-supplementary-x86_64-disc1.iso
rhel-5.2-server-supplementary-x86_64-disc2.iso
Comment 3 David Cantrell 2008-08-11 19:08:16 EDT
Releng,

I'm not sure how to handle this.  I am looking at RHEL-5.2 trees and see the i386 gpart package in the tree.  Are there any trees or media built that would lack this package?
Comment 4 Dennis Gregorovic 2008-08-12 12:30:35 EDT
The gpart.i386 package is available on the i386 ISOs and in the i386 channels on RHN.  Is there a particular need to add it to the x86_64 ISOs and/or channels? It's possible, but not something we do by default.
Comment 5 Jason Bradley Nance 2008-08-12 12:49:20 EDT
Ah.  Well, what has happened in this case is that I have machines with subscriptions, but no network access.

I don't understand why it wouldn't be in the x86_64 channel as an i386 rpm since there isn't a 64-bit counterpart.  Are 64-bit machines also subscribed to the 32-bit channels by default?
Comment 6 Dennis Gregorovic 2008-09-05 12:35:35 EDT
64-bit machines are not subscribed to the 32-bit channels.  

The general assumption is that source code should be portable,
so the only things with ExlcusiveArch are things that really are restricted
to only that arch.  I'm going to close this bug, but you may want to file a bug against gpart requesting an x86_64 build of the package.

Note You need to log in before you can comment on or make changes to this bug.