Bug 458721 - kernel and rpm get installed twice
kernel and rpm get installed twice
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 17:07 EDT by John Reiser
Modified: 2008-08-12 09:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 09:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2008-08-11 17:07:33 EDT
Description of problem: During a fresh graphical install from Fedora 10 DVD (alpha release), both of the packages kernel-2.6.27-0.166.rc0.git8.fc10.i386 and rpm-2.6.90-0.git8426.9.i386 appear twice in "installing ..." display messages, and both appear twice in /root/install.log.


Version-Release number of selected component (if applicable):
anacona-11.4.1.24

How reproducible: always


Steps to Reproduce:
1. fresh graphical install from DVD of Fedora 10 for i386 (alpha release)
2. uncheck "Office and Productivity", leaving only Base system
3.
  
Actual results: kernel and rpm packages apparently get installed twice.  kernel appears as 615 of 977, and as 977 of 977 [i.e., last].  rpm appears somewhere in the middle, and as 976 of 977 [i.e., next to last].


Expected results: Each package is installed only once.


Additional info:
Comment 1 Chris Lumens 2008-08-12 09:45:43 EDT
They're not actually getting installed twice.  The second time you see those messages, it's just re-accessing those two packages to run the %posttrans script.  They occur at the end because that's the end of the transaction.  Anyway, this is fixed in the rpm and anaconda that were released after the alpha, as the callback those messages are printed from is no longer run for %posttrans.

Note You need to log in before you can comment on or make changes to this bug.