Bug 458722 - Wrong preinstall script in qpidc package (useless system user created)
Wrong preinstall script in qpidc package (useless system user created)
Product: Fedora
Classification: Fedora
Component: qpidc (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Alan Conway
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-08-11 17:31 EDT by Arturas Moskvinas
Modified: 2009-01-09 01:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 01:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch which corrects qpidc.spec file (preinstall script is added into qpidd package, instead of qpidc) (405 bytes, patch)
2008-08-11 17:31 EDT, Arturas Moskvinas
no flags Details | Diff

  None (edit)
Description Arturas Moskvinas 2008-08-11 17:31:16 EDT
Created attachment 314001 [details]
Patch which corrects qpidc.spec file (preinstall script is added into qpidd package, instead of qpidc)

Description of problem:
Qpidd daemon (qpidd package) runs as qpidd user. Qpidd user is added in qpidc package, not while installing qpidd package

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install qpidc package (but do not include qpidd, scenario when only client library is needed)
2. Check /etc/passwd
Actual results:
qpidd user is added, although it is not needed for client library

Expected results:
No useless users created, while installing only qpidc package

Additional info:
qpidd user addition script should be placed into qpidd package, not into qpidc.
Comment 1 Bug Zapper 2008-11-26 06:05:36 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 2 Bug Zapper 2009-01-09 01:43:13 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.