Bug 458734 - Can't create virtual machine guest
Can't create virtual machine guest
Status: CLOSED DUPLICATE of bug 453491
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 20:30 EDT by Russell Doty
Modified: 2013-01-09 23:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 15:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2008-08-11 20:30:23 EDT
Description of problem:
Unable to create/install/run guest operating systems. Running on AMD Phenom X4 (Barcelona) with 4GB memory.

Version-Release number of selected component (if applicable): Fedora 9 X86-64 Virtual Machine Manager QEMO, fully updated


How reproducible:
Every Time


Steps to Reproduce:
1. Start Virtual Machine Manager
2. Start localhost qemu
3. Select "new"
4. Accept fully virtualized. X86_64, qemu
5. Select OS_type = Linux, OS_Variant = Generic 2.6.x kernel (note: other choices yield same result)
6. Install from DVD, "Fedora 9 x86_64 DVD" (same DVD that was used to install bare metal OS on this machine)
7. Simple File, 10,000MB
8. Virtual Network (default)
9. VM MAX memory 512 MB (default) VCPUs: 1 (default)
10. select FINISH
11. After storage allocation completes, message box pops up saying "Unable to complete install: 'virDomainCreateLinux() failed internal error Timed out while reading monitor startup output'"
12. select CLOSE
13. select FINISH again from "Create a new virtual system" box
14. Virtual machine is created with blue "Welcome to Fedora 9" startup screen
15. Can't select menu choice with mouse. Press 'enter' to install F9
16. Select language defaults.
17. When you get to the screen looking for installation media, receive "Fedora disk not found in any of your cdrom drives" message



  
Actual results:


Expected results:


Additional info:
Comment 1 Russell Doty 2008-08-11 20:32:23 EDT
Complete error message from step 11:

unable to complete install '<class 'libvirt.libvirtError'> virDomainCreateLinux() failed internal error Timed out while reading monitor startup output
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 651, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 845, in start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 866, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 841, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error Timed out while reading monitor startup output
'
Comment 2 Julian G 2008-12-01 05:33:33 EST
Did you enable SELinux?
Comment 3 Russell Doty 2008-12-01 10:20:22 EST
SELinux is set to permissive mode. I've had problems with SELinux and virtulization in the past, so one of the first things I did  was to set it to 
permissive mode.

I am also seeing this problem with Fedora 10.
Comment 4 Cole Robinson 2008-12-01 15:03:07 EST

*** This bug has been marked as a duplicate of bug 453491 ***

Note You need to log in before you can comment on or make changes to this bug.