Bug 458738 - tiny text in installer, screen hard to read
tiny text in installer, screen hard to read
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-08-11 21:08 EDT by Tom Horsley
Modified: 2008-11-04 22:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 22:01:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture from installer screen (27.70 KB, image/jpeg)
2008-10-02 18:16 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2008-08-11 21:08:35 EDT
Description of problem:

Previous versions of fedora have somehow expanded the 800x600 installer
screen to fill my 1920x1080 HD monitor, with Fedora 10 alpha, I get
a small, very hard to read 800x600 screen drawn in the middle of the
monitor with a vast black border and just barely readable fonts
for the text.


Version-Release number of selected component (if applicable):

This is from the Fedora-10-Alpha-x86_64-DVD install

How reproducible:

Only installed once, but I assume every time.

Steps to Reproduce:
1. boot off DVD to install
2. squint at tiny screen
3.
  
Actual results:

tiny little installer screen

Expected results:

bit enough fonts to read

Additional info:
Comment 1 Tom Horsley 2008-08-12 17:24:43 EDT
Just to make sure I wasn't remembering different hardware,
I just tried booting the Fedora 9 installer on this same
machine, and just as I remembered, I get a screen filling
install window with fonts big enough to read, so something
is definitely different just in Fedora 10 alpha.
Comment 2 Chris Lumens 2008-09-03 12:14:37 EDT
Looks like we must have lost xrandr from the install.img at some point during our scripts cleanups.
Comment 3 Tom Horsley 2008-10-02 18:16:04 EDT
Something is still busted. The installer is filling the whole screen
now, but the fonts are still tiny and unreadable. Having seen things
like this many times in the past, it is probably selecting fonts
using a point size calculation and the actual physical dots per inch of
the monitor, which, in this case with a 42" diagonal 1920x1080 screen
works out to 54DPI, which makes unreadable tiny fonts for typical
point sizes like 10 or 12 points. I'll attach a photograph of a big old
next button with tiny little fuzzy text for "Next" inside it.

If you could simply force it to use 96DPI, it almost always looks good
(lots better than 54 anyway).
Comment 4 Tom Horsley 2008-10-02 18:16:53 EDT
Created attachment 319300 [details]
picture from installer screen
Comment 5 mail@romal.de 2008-10-06 16:31:24 EDT
I have the same problem: F10Beta starts Anaconda and the font is unreadable small. The layout is ok and fills the whole screen, but the font is to small to read. I use a Nvidia 6600G graphics card connected via DVI to a HDTV (1360*768).
Comment 6 Adam Jackson 2008-10-15 13:16:46 EDT
Forcing 96 seems like a good idea to me.  anaconda's special in this regard on account of the fixed layout, and I'm not convinced we want to clip DPI in the server in the general case.

Fixed in b925aec1cc9602eb01f907f967e2704952eb6727, should be in the next build of anaconda.
Comment 7 Will Woods 2008-10-24 15:02:08 EDT
That commit should be in anaconda-11.4.1.50-1, but the fonts are still tiny. X is definitely running with -dpi 96, and X.log shows:
  (++) NV(0): DPI set to (96, 96)
Is there some other piece still missing?
Comment 8 mail@romal.de 2008-10-27 03:19:12 EDT
I`m installing todays rawhide on the machine I had the problem and it's fixed for me. Thanks.
Comment 9 David Cantrell 2008-10-27 03:37:11 EDT
Closing per comment #8.
Comment 10 Will Woods 2008-10-27 14:17:39 EDT
Not *entirely* fixed. There are two bugs in the original report; the one about fonts being unreadably tiny is still present in today's rawhide (anaconda-11.4.1.51) for me.
Comment 11 Adam Jackson 2008-10-29 15:02:42 EDT
Right, for randr 1.2 machines, the DPI would be derived from the actual screen size regardless of what we said on the command line.  Down not across.

Fixed even harder in a6b91cb33a40b31a014e2364e6de38c5f291c5e6, should be in 11.4.1.53.
Comment 12 Tom Horsley 2008-11-04 21:22:03 EST
I just installed the F10 Preview from the i386 DVD image, and things look
lots better. I'm back to a small installer screen centered in the big monitor
instead of stretched to fill the screen, but the fonts are plenty big enough
to read now, and I think I like the small screen better anyway, at least the
aspect ratio is correct instead of being stretched like it would be to fill
the screen. This version definitely looks good to me now.

Note You need to log in before you can comment on or make changes to this bug.