Bug 458745 - Video tearing with X700 and LCD
Video tearing with X700 and LCD
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 22:33 EDT by Chris Adams
Modified: 2009-07-14 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Picture of glxgears (863.53 KB, image/jpeg)
2008-08-11 22:33 EDT, Chris Adams
no flags Details
X config (814 bytes, text/plain)
2008-08-11 22:35 EDT, Chris Adams
no flags Details
X log file (37.13 KB, text/plain)
2008-08-11 22:36 EDT, Chris Adams
no flags Details
X log file (71.50 KB, text/plain)
2008-12-02 18:23 EST, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2008-08-11 22:33:00 EDT
Created attachment 314034 [details]
Picture of glxgears

I have an ATI Radeon X700 XL connected via a DVI-to-HDMI cable (I also tried a DVI-to-DVI) to a Samsung SyncMaster 2493HM.  I am running at 1920x1200, the panel native resolution.  The problem is that I get video tearing, especially with high-refresh things like glxgears.  By tearing I mean horizontal lines flickering across the screen, and the whole screen flickering horizontally.

I took a picture of glxgears running.  Of course the gears are blurred (and the picture is kind of grainy), but you can see the horizontal lines along the left edge of the screen and to the right of the gears.  The whole screen is doing this (not just those spots), but that was the best picture I could come up with.

It also happens when I switch desktop workspaces sometimes (and sometimes worse than other times).
Comment 1 Chris Adams 2008-08-11 22:35:48 EDT
Created attachment 314036 [details]
X config

My config uses EXA; I also tried with the default XAA and had the same results.
Comment 2 Chris Adams 2008-08-11 22:36:38 EDT
Created attachment 314037 [details]
X log file
Comment 3 Chris Adams 2008-08-11 22:49:52 EDT
This can even happen when something is happening in another workspace (i.e. nothing is updating the actual display).  For example, I clicked on this bug and switched to another workspace to check something while this page loaded, and the screen jumped/flickered when Firefox loaded and rendered the page.
Comment 4 Jóhann B. Guðmundsson 2008-12-01 06:09:31 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 5 Chris Adams 2008-12-01 18:45:01 EST
I tried these on an otherwise F9 system, pulling in some dependencies from rawhide (alsa-utils fedora-logos hal hal-libs initscripts libdrm libvolume_id mkinitrd nash pciutils-libs plymouth plymouth-libs plymouth-scripts udev).

Now my cursor is messed up (a garbage block) and I have no acceleration (glxgears gives me ~44 FPS).  I don't get any tearing now.
Comment 6 Matěj Cepl 2008-12-02 15:17:00 EST
Could we get fresh /var/log/Xorg.0.log, please?
Comment 7 Chris Adams 2008-12-02 18:23:16 EST
Created attachment 325445 [details]
X log file

I had switched back to the F9 versions, so I pulled new packages from koji (kernel 2.6.27.7-134.fc10 and xorg-x11-drv-ati 6.9.0-61.fc10).  Also, just to make sure nothing in my xorg.conf was weird, I tried with it renamed it out of the way (it made no difference).  With today's packages, the cursor is fine again, but I still get 38-44 FPS from glxgears.
Comment 8 Bug Zapper 2009-06-09 22:26:31 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-07-14 12:45:43 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.