Bug 458771 - glibc doesn't compile on alpha - patches included
glibc doesn't compile on alpha - patches included
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 03:25 EDT by Oliver Falk
Modified: 2008-09-17 08:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 22:49:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mike Frysingers patch fixing asm/elf.h and asm/page.h compile problem (6.03 KB, patch)
2008-08-12 03:25 EDT, Oliver Falk
no flags Details | Diff
alpha does not have __NR_creat (patch from gentoo) (372 bytes, patch)
2008-08-12 03:26 EDT, Oliver Falk
no flags Details | Diff
Oliver Falks patch to fix duplicate symbol __libc_alpha_cache_shape (449 bytes, patch)
2008-08-12 03:28 EDT, Oliver Falk
no flags Details | Diff
Richard Hendersons (rth) patch to fix PTR_MANGLE compile problem (3.28 KB, patch)
2008-08-12 03:29 EDT, Oliver Falk
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 6896 None None None Never

  None (edit)
Description Oliver Falk 2008-08-12 03:25:33 EDT
Created attachment 314056 [details]
Mike Frysingers patch fixing asm/elf.h and asm/page.h compile problem

There are a few patches required to compile glibc 2.8.90 on alpha. I'll attach them; Please consider them for inclusion. Jakub, please also consider to include these patches upstream, but note: Some of those patches are already committed somewhere I expect.
Comment 1 Oliver Falk 2008-08-12 03:26:22 EDT
Created attachment 314057 [details]
alpha does not have __NR_creat (patch from gentoo)
Comment 2 Oliver Falk 2008-08-12 03:28:05 EDT
Created attachment 314060 [details]
Oliver Falks patch to fix duplicate symbol __libc_alpha_cache_shape
Comment 3 Oliver Falk 2008-08-12 03:29:26 EDT
Created attachment 314062 [details]
Richard Hendersons (rth) patch to fix PTR_MANGLE compile problem
Comment 4 Ulrich Drepper 2008-09-16 22:49:58 EDT
These are changes which have to go in upstream.  File the bug in the upstream BZ.  You might as well assign the new bug directly to rth@gcc.gnu.org since rth has to check in the changes.
Comment 5 Oliver Falk 2008-09-17 04:49:21 EDT
Reported upstream. See 'External Bugs' for reference.
Ulrich, how can we make sure that these upstream fixes find their way into Fedora? Isn't Fedora glibc a separate branch of upstream glibc or so!?
Comment 6 Ulrich Drepper 2008-09-17 08:37:54 EDT
rawhide always follows the cvs head.  There is nothing special to do.

Note You need to log in before you can comment on or make changes to this bug.