Bug 458786 - Missing modules discovered running spamassassin -D --lint
Missing modules discovered running spamassassin -D --lint
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 05:51 EDT by Eli Wapniarski
Modified: 2008-08-13 02:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 11:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2008-08-12 05:51:17 EDT
After running spamassassin -D --lint, Spamassassin reports that

[9276] dbg: diag: module not installed: IP::Country::Fast ('require' failed)
[9276] dbg: diag: module not installed: Net::Ident ('require' failed)

The modules are nowhere to be found in the Fedora repositories. I had to install them using cpan.

Please include or advise.

Thank you.

Eli
Comment 1 Marcela Mašláňová 2008-08-12 06:19:36 EDT
I don't see these modules in requires. Could spamassassin maintainer check whether we're missing some modules or not?
Comment 2 Warren Togami 2008-08-12 11:32:03 EDT
These are optional and certainly not required.  If you want the functionality enabled by these modules then someone needs to go through the effort of adding them to Fedora.
Comment 3 Eli Wapniarski 2008-08-12 12:51:31 EDT
OK.. Good to know.

So what's up with the messages from the lint test?
Comment 4 Marcela Mašláňová 2008-08-13 02:24:30 EDT
I can't say, I don't have these messages with default settings.

Also I don't want include module IP::Country::Fast into Fedora, because it hasn't specified license.

Note You need to log in before you can comment on or make changes to this bug.