Bug 458787 - Memory leak in scim-bridge message handling
Memory leak in scim-bridge message handling
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scim-bridge (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Peng Huang
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 06:11 EDT by Olivier Fourdan
Modified: 2013-04-12 15:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 06:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport the fix from current upstream version (320 bytes, patch)
2008-08-12 06:11 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2008-08-12 06:11:25 EDT
Created attachment 314079 [details]
Backport the fix from current upstream version

Description of problem:

scim-bridge 0.4.5 in RHEL5 is leaking the DBUS message header

Version-Release number of selected component (if applicable):

scim-bridge-0.4.5-7.el5

How reproducible:

100% reproducible.

Steps to Reproduce:
1. Install scim-bridge
2. Run gnome-terminal
3. Monitor scim-bridge process size while entering input in gnome-terminal
  
Actual results:

scim-bridge size increases continuously

Expected results:

scim-bridge size does not leak memory

Additional info:

This memory leak was fixed is a recent upstream version:

From the ChangeLog:

    2007-07-01 17:48  ryo-dairiki

            * common/scim-bridge-message.c, doc/Makefile.am: - Fix one memory
              leak in the messaging bus.

I am attaching the backport of this fix to this ticket. This is fairly urgent issue because this may cause a delay to a large deployment that the customer is planning.
Comment 2 Denise Dumas 2008-08-13 09:10:12 EDT
scim-bridge is actually owned by i18n engineering, Yu Shao's team, not by BaseOS. I'm adding Yu to the distribution list and forwarding the hotfix request.
Denise
Comment 3 Peng Huang 2008-08-14 02:08:56 EDT
Patch is ready. Wait for flags.
Comment 17 errata-xmlrpc 2009-04-15 06:26:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0426.html

Note You need to log in before you can comment on or make changes to this bug.