Bug 458795 - local hard disk install doesn't work
local hard disk install doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 07:27 EDT by Tom Horsley
Modified: 2008-08-14 13:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-14 13:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-08-12 07:27:59 EDT
Description of problem:

When I attempted to install Fedora-10-Alpha-x86_64-DVD from the iso
image on a local hard disk, it always says it can't find any iso images
(tried a few times, carefully checking the path names I typed with
same results each time).

I start the installation without a CD by copying the isolinux/vmlinuz
and isolinux/initrd.img files off the DVD iso image and into my /boot
partition, where I then make a grub entry to boot that kernel (didn't
specify any boot options).

I then boot that kernel, and once it gets past looking for media on
/dev/sr0 (which seems to take forever to timeout), it asks me where
to find it, and I can tell it to use local disk install technique.

I then pick the partition from the list, and type the directory name
holding the .iso image in the text field, and it always says it can't
find any iso images.

I've used this exact same technique to install the last few Fedora
releases, so it has definitely worked previously (and the other ones
never had the interminable timeout on /dev/sr0 either).

Version-Release number of selected component (if applicable):

Whatever shipped on the Fedora-10-Alpha-x86_64-DVD image.

How reproducible:

Tried at least three times, with careful checking of spelling of
directory names

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:

can't find iso images

Expected results:

installer starts up

Additional info:

I first had the iso image on an external USB drive, but copied it to
a local sata disk when that didn't work, but the sata drive got the
same results.
Comment 1 Chris Lumens 2008-08-14 13:25:54 EDT
Yeah this is a bit of a change from F9 and earlier, which we are going to document in a release note.

First, the loader UI screen there is really looking for the stage2.img file, not the ISO images any more.  I have cleaned up the strings a bit to make that clearer.  Second, we no longer go looking inside the ISO images themselves for the stage2.img.  What you'll need to do is create an images/ directory in the same directory as your ISO images and place stage2.img inside that.  You can also put any product.img or updates.img you would like into that same directory.

I'm going to close this as RAWHIDE because of the various string changes I have made here to help clear up some of the confusion, as well as for the documentation changes I've made on the wiki describing this behavior.

Note You need to log in before you can comment on or make changes to this bug.