Bug 458820 - Eclipse hangs opening text file
Eclipse hangs opening text file
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 10:21 EDT by Robin Green
Modified: 2008-08-12 17:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 17:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 243887 None None None Never

  None (edit)
Description Robin Green 2008-08-12 10:21:16 EDT
Description of problem:
Eclipse gets stuck in a loop if you try to open a file in its internal text editor.

Version-Release number of selected component (if applicable):
eclipse-platform-3.4.0-19.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. start eclipse
2. create new project
3. create a text file "foo" in that project
  
Actual results:
Hangs when you click Finish in the New File dialog box.

Expected results:
New empty file should be opened in Eclipse's internal text editor.

Additional info:
In the error log, it says that the text editor component seems to be trying to create itself.
Comment 1 Andrew Overholt 2008-08-12 11:22:18 EDT
Can you try this and see if it fixes it for you?

yum --enablerepo=rawhide install tomcat5-{jasper,jsp-2.0-api,servlet-2.4-api}
Comment 2 Andrew Overholt 2008-08-12 11:29:54 EDT
My comments about tomcat still stand, but if that wasn't the problem, I can't duplicate.  I have never run into the printers issue that the upstream bug references.  I wonder why I haven't?
Comment 3 Robin Green 2008-08-12 11:43:08 EDT
(In reply to comment #1)
> Can you try this and see if it fixes it for you?
> 
> yum --enablerepo=rawhide install tomcat5-{jasper,jsp-2.0-api,servlet-2.4-api}

yum says they're all already installed and latest version

(In reply to comment #2)
> My comments about tomcat still stand, but if that wasn't the problem, I can't
> duplicate.

I can duplicate it on OpenJDK, and latest Sun JDK 1.6; and on both eclipse 3.3.2 and 3.4.0 from eclipse.org. I suspect it is something to do with the rawhide gtk version (gtk2-2.13.6-3.fc10.i386).

Also, I'm running rawhide on VirtualBox 1.6.4 OSE on Mac OS X 10.5.

> I have never run into the printers issue that the upstream bug
> references.  I wonder why I haven't?

beats me - btw, I tried the system property workaround mentioned there, and it didn't work.
Comment 4 Robin Green 2008-08-12 11:48:46 EDT
Here's a JVM stacktrace from the fedora-shipped eclipse running on the fedora-shipped OpenJDK.

I'm punting this to the gtk2 component.

"main" prio=10 tid=0x089c4000 nid=0x13fa runnable [0xbf827000..0xbf828be0]
   java.lang.Thread.State: RUNNABLE                                       
        at org.eclipse.swt.internal.gtk.OS._gtk_enumerate_printers(Native Method)
        at org.eclipse.swt.internal.gtk.OS.gtk_enumerate_printers(OS.java:6459)  
        at org.eclipse.swt.printing.Printer.getPrinterList(Printer.java:88)      
        at org.eclipse.jface.text.TextViewer.isPrintable(TextViewer.java:4160)   
        at org.eclipse.jface.text.TextViewer.canDoOperation(TextViewer.java:3697)
        at org.eclipse.jface.text.source.SourceViewer.canDoOperation(SourceViewer.java:701)
        at org.eclipse.ui.texteditor.TextOperationAction.update(TextOperationAction.java:157)
        at org.eclipse.ui.texteditor.TextOperationAction.<init>(TextOperationAction.java:103)
        at org.eclipse.ui.texteditor.AbstractTextEditor.createActions(AbstractTextEditor.java:5526)
        at org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.createActions(AbstractDecoratedTextEditor.java:1090)
        at org.eclipse.ui.editors.text.TextEditor.createActions(TextEditor.java:118)                                 
        at org.eclipse.ui.texteditor.AbstractTextEditor.createPartControl(AbstractTextEditor.java:3361)              
        at org.eclipse.ui.texteditor.StatusTextEditor.createPartControl(StatusTextEditor.java:53)                    
        at org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.createPartControl(AbstractDecoratedTextEditor.java:394)
        at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:661)                           
        at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:428)                                 
        at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:594)                      
        at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:306)                                               
        at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:180)                   
        at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:270)      
        at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)           
        at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:473)
        at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1256)                            
        at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1209)                                            
        at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1608)                                                
        at org.eclipse.ui.internal.PartStack.add(PartStack.java:499)                                                      
        at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103)                                                  
        at org.eclipse.ui.internal.PartStack.add(PartStack.java:485)                                                      
        at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:112)                                                  
        at org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)                             
        at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:217)                                
        at org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAreaHelper.java:207)                                  
        at org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:779)                                  
        at org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:678)                         
        at org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:639)
        at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2817)
        at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2729)
        at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2721)
        at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2673)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2668)
        at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2652)
        at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2643)
        at org.eclipse.ui.ide.IDE.openEditor(IDE.java:646)
        at org.eclipse.ui.ide.IDE.openEditor(IDE.java:605)
        at org.eclipse.jdt.internal.ui.javaeditor.EditorUtility.openInEditor(EditorUtility.java:318)
        at org.eclipse.jdt.internal.ui.javaeditor.EditorUtility.openInEditor(EditorUtility.java:160)
        at org.eclipse.jdt.ui.actions.OpenAction.run(OpenAction.java:228)
        at org.eclipse.jdt.ui.actions.OpenAction.run(OpenAction.java:207)
        at org.eclipse.jdt.ui.actions.SelectionDispatchAction.dispatchRun(SelectionDispatchAction.java:274)
        at org.eclipse.jdt.ui.actions.SelectionDispatchAction.run(SelectionDispatchAction.java:250)
        at org.eclipse.jdt.internal.ui.packageview.PackageExplorerActionGroup.handleOpen(PackageExplorerActionGroup.java:363)
        at org.eclipse.jdt.internal.ui.packageview.PackageExplorerPart$5.open(PackageExplorerPart.java:603)
        at org.eclipse.jface.viewers.StructuredViewer$2.run(StructuredViewer.java:820)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
        at org.eclipse.core.runtime.Platform.run(Platform.java:886)
        at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:48)
        at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
        at org.eclipse.jface.viewers.StructuredViewer.fireOpen(StructuredViewer.java:818)
        at org.eclipse.jface.viewers.StructuredViewer.handleOpen(StructuredViewer.java:1079)
        at org.eclipse.jface.viewers.StructuredViewer$6.handleOpen(StructuredViewer.java:1183)
        at org.eclipse.jface.util.OpenStrategy.fireOpenEvent(OpenStrategy.java:263)
        at org.eclipse.jface.util.OpenStrategy.access$2(OpenStrategy.java:257)
        at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:297)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3401)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3033)
        at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
        at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
        at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
Comment 5 Robin Green 2008-08-12 12:18:16 EDT
This is caused by cups being stopped on localhost.

Instead of hanging for a long time, there should be some kind of informative error message. (Or better yet, in the case of Eclipse opening a text file, ignore the problem.)
Comment 6 Andrew Overholt 2008-08-12 13:06:15 EDT
Since this is an upstream bug, can we track it there?
Comment 7 Robin Green 2008-08-12 17:02:18 EDT
OK - closing this bug

Note You need to log in before you can comment on or make changes to this bug.