Bug 458831 - xen-3.1.2-5.fc8 kills host networking
xen-3.1.2-5.fc8 kills host networking
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 11:37 EDT by Orion Poplawski
Modified: 2008-08-15 17:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-15 17:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log files (2.85 KB, application/x-tar)
2008-08-12 11:45 EDT, Orion Poplawski
no flags Details
config.sxp for old F9 domain (2.23 KB, text/plain)
2008-08-12 12:07 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2008-08-12 11:37:17 EDT
Description of problem:

With the xen-3.1.2-5.fc8 update, networking on the host is shutdown when xend starts.  It looks like I end up with a peth0 interface with no IP and a tmpbridge (or similar) with the original IP of the host.
Comment 1 Orion Poplawski 2008-08-12 11:45:38 EDT
Created attachment 314107 [details]
Log files

Log files from xend start including ifconfig before and after starting xend.
Comment 2 Orion Poplawski 2008-08-12 12:06:24 EDT
Okay, scratch the update part.  Looks like the culprit may have been a failed
attempt to install a F10 guest at the same time as I did the update.  Reverting
to 3.1.2-2 did not help.  I also tried to remove the config for the newer F10 guest but that didn't help.  Now I'm left with a F9 x86_64 guest that had been working for a while but now seems to crash the networking when brought up.  I'll attach the config.
Comment 3 Orion Poplawski 2008-08-12 12:07:43 EDT
Created attachment 314110 [details]
config.sxp for old F9 domain
Comment 4 Mark McLoughlin 2008-08-14 14:03:14 EDT
Orion: if you think the update didn't cause this, could you kill the -1 karma in bodhi

Your networking issue is strange. This:

  device eth0 already exists; can't create bridge with the same name

suggests that when this:

  create_bridge ${tdev}

is called, that tdev=eth0; but clearly from your ifconfig output, tdev=tmpbridge

dunno, try add "set -x" to network-bridge and looking at the output in xend-debug.log
Comment 5 Orion Poplawski 2008-08-15 17:18:43 EDT
After cleaning up some problems it seems to be working now.  I'll try to drop the -1 karma when bodhi is back up.

Note You need to log in before you can comment on or make changes to this bug.