Bug 458858 - rhn-client-tools should be sanitized to not hit rhn.redhat.com
rhn-client-tools should be sanitized to not hit rhn.redhat.com
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Mike McCune
:
Depends On:
Blocks: space07
  Show dependency treegraph
 
Reported: 2008-08-12 13:49 EDT by Mike McCune
Modified: 2009-12-07 07:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-07 07:02:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2008-08-12 13:49:53 EDT
If we patch rhnlib to not hit rhn.redhat.com for updates this library will be more generically useful to other distributions of Linux (CentOS and Fedora).
Comment 1 Pradeep Kilambi 2008-09-26 15:17:43 EDT
hmm not sure I completely understand what this bug is intended for, rhnlib gets the serverUrl info directly from what the update client sends it. rhnlib is a generic wrapper around python xmlrpclib which has no info of rhn.redhat.com (code wise). So up2date/yum reads the /etc/sysconfig/rhn/up2date and creates an rhnserver object thats being referenced to talk to the xmlrpc layer on the server through rhnlib.

unless you're referring to the url comment references pointing rhn.redhat.com in the spec file and other setup info?
Comment 2 Mike McCune 2008-10-16 19:43:19 EDT
ok, so by default if you install:

yum install rhn-client-tools rhn-check rhn-setup rhnsd m2crypto yum-rhn-plugin

from our spacewalk Fedora repo you get:

# grep rhn.redhat.com /etc/sysconfig/rhn/*
/etc/sysconfig/rhn/up2date:serverURL=https://xmlrpc.rhn.redhat.com/XMLRPC

and rhnreg_ks will default to talking to xmlrpc.rhn.redhat.com

We should make it so we do NOT default that to xmlrpc.rhn.redhat.com so our client bits can be included in CentOS and other distros.

that make sense?
Comment 3 Pradeep Kilambi 2008-10-16 20:21:30 EDT
ah thats rhn-client-tools not rhnlib. ok I'll look into it.

Thanks
Comment 4 Jesus M. Rodriguez 2008-11-25 14:21:39 EST
changed summary to be 'rhn-client-tools should be sanitized to not hit rhn.redhat.com' instead of 'rhnlib should be sanitized to not hit rhn.redhat.com'
Comment 5 Miroslav Suchý 2009-12-02 11:06:14 EST
Done in commit cd925d940357d145c7106c1c3ed6ed12dff29e9d

Changed url from xmlrpc.rhn.redhat.com to enter.your.server.url.here
Comment 6 Miroslav Suchý 2009-12-07 07:02:36 EST
Spacewalk 0.7 released.

Note You need to log in before you can comment on or make changes to this bug.