Bug 458869 - Order is not maintained when getting list of IPA servers from config and DNS
Order is not maintained when getting list of IPA servers from config and DNS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise IPA
Classification: Retired
Component: ipa-server (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Ben Levenson
:
Depends On:
Blocks: 453489
  Show dependency treegraph
 
Reported: 2008-08-12 15:19 EDT by Rob Crittenden
Modified: 2015-01-21 10:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 10:18:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2008-08-12 15:19:27 EDT
Description of problem:

When we get the list of IPA servers we are supposed to pull it first from /etc/ipa/ipa.conf and then append any DNS service records that are there. This way if someone wants to override the server they can do so locally.

Version-Release number of selected component (if applicable):

ipa-1.0.0-15

The problem is that in an effort to de-dupe the list it is run through: list(set(list_of_servers)) in ipa/config.py

This changes the order of the sort.
Comment 1 Martin Nagy 2008-09-16 19:03:33 EDT
master: a9e8a72059ca5a6db13a9835d20f68dd16ce9a7a
Comment 2 Michael Gregg 2008-11-21 18:22:27 EST
Would dev please verify that list(set(list_of_servers)) provides the list of servers in the correct sequence please?
Comment 3 Martin Nagy 2008-11-22 04:47:45 EST
It does not, that was the cause of the bug. There's a different code in place now that preserves the order.
Comment 4 Michael Gregg 2008-11-24 13:16:32 EST
So does that mean this bug would fail QA? or would this mean that it can be closed?
Comment 5 Martin Nagy 2008-11-25 05:37:38 EST
Sorry, I didn't realize that there was no how-to test. If the ipa.conf contains this:
server=s1.example.com,s2.example.com,s1.example.com

And the SRV record in DNS points to s3.example.com, then when executing ipa command, like ipa-finduser, with the -v option, the order of the servers that are tried shold be s1, s2, s3 and there should be one attempt at each only.
Comment 6 Michael Gregg 2008-11-25 18:31:28 EST
Seems to work:
Connecting to IPA server: https://ipaqa-64vm.dsqa.sjc2.redhat.com/ipa/xml
Connecting to IPA server: https://iparhel5-64vm.dsqa.sjc2.redhat.com/ipa/xml

Closed as verified
Comment 10 Martin Kosek 2015-01-21 10:18:59 EST
"Red Hat Enterprise IPA" product is not used or maintained. As this bug has a VERIFIED or RELEASE_PENDING status, it can be safely closed.

For further requests for the Red Hat Enterprise Linux Identity Management, please consider filing a Bug to RHEL "ipa" component.

Note You need to log in before you can comment on or make changes to this bug.