Bug 458879 - [RFE] Satellite - custom channels need mechanism of managing custom comps information (for yum group operations to work, among others)
[RFE] Satellite - custom channels need mechanism of managing custom comps inf...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.3
All Linux
high Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks: sat-nextgen
  Show dependency treegraph
 
Reported: 2008-08-12 16:26 EDT by Issue Tracker
Modified: 2016-12-07 15:47 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-07 15:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-08-12 16:26:22 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-08-12 16:26:24 EDT
Description of problem:

Customers unable to install groups with yum groupinstall command from custom cloned channels.  We have a current bugzilla working on groupinstall failure for both cloned and Red Hat based cloned channels.

https://bugzilla.redhat.com/show_bug.cgi?id=452046


How reproducible:

any groupinstall from cloned channels fails on satellite

Steps to Reproduce:

* Clone a channel on satellite
* attempt a groupinstall from the cloned channel


This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 197946
Comment 2 Issue Tracker 2008-08-12 16:26:25 EDT
Who is the customer?

SAS 

What is the exact nature of the problem trying to be solved with this
request?

Satellite - custom channel - customers are unable to use the groupinstall
option in yum.  Groupinstall option fails when attempting an install from
a  custom channel

What, if any, business requirements are satisfied by this request? (What
is the use case context?)

customers would have the ability to push custom packages to a channel and
groupinstall when kickstarting and after installation. 

List the functional requirement(s) for performing the action(s) that are
not presently possible. Please focus on describing the problem related
requirements without projecting any specific solution.

groupinstall for custom channels


Each functional requirement must have clear acceptance criteria so Red Hat
understands what success looks like. If test cases can be provided this
would be even more ideal (bonus points for RHTS test cases).

What is the desired release vehicle to satisfy these requirements? Major
release Minor release

Minor, Medium

Please justify with reference to the release vehicle policy described in
the RHEL Inclusion Criteria wiki page

Customers use this option while deploying systems.


What package(s) are affected by this RFE? (List "new" if new technology is
likely to be required) 

rhns


This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 197946
Comment 3 Issue Tracker 2008-08-12 16:26:27 EDT
Who is the Sales Sponsor?

Justin Jones

What is the Red Hat business opportunity with this customer?

The business opportunity at SAS is large. 

What is the status and risk to the contract if this RFE is not satisfied?

Status of the account is not as favorable as it once was simply due to the
fact that a lot of issues have had bumps along the way.


Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 197946
Comment 4 Issue Tracker 2008-08-12 16:26:28 EDT
Rob,

Just had a quick discussion with jsherrill about this.  Seems this is a
bug AND that it's just been fixed.

https://bugzilla.redhat.com/show_bug.cgi?id=452046

If you want the hotfix, I've been told you'll have to file a new hotfix
request.  I'm going to de-escalate this, but feel free to re-escalate if I
missed something.

--jwest

jwest assigned to issue for SEG - Feature Request.

This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 197946
Comment 5 Issue Tracker 2008-08-12 16:26:30 EDT
Jeremy, here is the information I have so far:

The hotfix works for clones of red hat channels but does not work for
clones of custom channels or non-cloned custom channels.

The RFE is for clones of custom channels and non-cloned custom channels.

This issue is linked to IT 192578

https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=192578

Please see comment:

Event posted 08-05-2008 04:11pm EDT

"an RFE is needed for getting this implemented for *custom* (those not
cloned from RH channels) channels and *custom* packages (those not cloned
from the original RH channels)."

We could possibly look at this from the customers point of view and see it
as a bug not and RFE.

Regards,
Robert




This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 197946
Comment 114 Mike McCune 2013-07-11 11:55:42 EDT
Satellite 6 maintains comps and allows for the use of groupinstall and other group operations for all custom repositories.
Comment 117 Mike McCune 2013-10-17 16:57:25 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 118 Corey Welton 2014-06-23 12:36:56 EDT
Testing of custom repos containing groups can be done using the following repo

http://lzap.fedorapeople.org/fakerepos/zoo4/
Comment 119 Mike McCune 2014-06-23 14:06:04 EDT
This RFE is still open and is for adding support for Satellite 6 to be able to have custom yum groups information uploaded and added to repositories managed within the Satellite.

We can currently sync and publish yum group information from the CDN or custom repos but we don't offer a way to upload directly or create them from within the repositories already created.
Comment 120 Bryan Kearney 2016-12-07 15:47:38 EST
I do not see us adding this functionality in the near future into Satellite. Customers should instead add this data to repositories they mirror. If this is a business issue, please feel free to email me or re-open this bug wih additional information.

Note You need to log in before you can comment on or make changes to this bug.