Bug 458901 - (Computer-freeze) cannot start udev - computer cannot start with 2.6.26 kernels
cannot start udev - computer cannot start with 2.6.26 kernels
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 22:03 EDT by Joshua Covington
Modified: 2008-09-30 20:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.26.3-27.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-01 16:19:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg-2.6.26.2-14.fc9.i686 (27.25 KB, application/octet-stream)
2008-08-12 22:03 EDT, Joshua Covington
no flags Details
dmesg acpi=off (21.94 KB, application/octet-stream)
2008-08-13 05:22 EDT, Joshua Covington
no flags Details
dmesg-debug-udev (98.72 KB, application/octet-stream)
2008-08-22 12:03 EDT, Joshua Covington
no flags Details
linux-2.6-x86-32-amd-c1e-force-timer-broadcast-late.patch (1.47 KB, application/octet-stream)
2008-09-01 16:17 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2008-08-12 22:03:00 EDT
Created attachment 314168 [details]
dmesg-2.6.26.2-14.fc9.i686

Description of problem:
My computer freezes.
All kernels from 2.6.26 tree seems to "lock" themselves. They all stop after "Starting udev:". The dmesg doesn't show any oopses or other problems. The only change in comparison to 2.6.25 is "ACPI: Core revision 20080321"
In order to go further i have to keep the backspace key pressed. then everything works normal. if i let the key everything stops again. For example
in konsole, after i type a command and press enter nothing happens until i press and keep backspace pressed.
Everything works fine only with the backspace pressed.
The problem doesn't exist with 2.6.25 kernels.


Version-Release number of selected component (if applicable):
2.6.26.2-14.fc9.i686
2.6.26.1-9.fc9.i686

How reproducible:
is the kernel on aspire 5051

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Everything freezes until the backspace is pressed


Expected results:
make it work


Additional info:
Comment 1 Joshua Covington 2008-08-13 05:22:28 EDT
Created attachment 314182 [details]
dmesg acpi=off

With acpi=off the system boots normally (as far as possible). I'll try another acpi options and report later.
Comment 2 Joshua Covington 2008-08-14 07:04:14 EDT
Actually I need to keep pressed at least one key for it to work flawlesly. Not just the backspace. MAybe irq problems with keyboard?
Comment 3 Joshua Covington 2008-08-14 08:13:11 EDT
Maybe the problem is not acpi related. the dmesg doesn't show any problems and the kernel loads fine. Maybe it is something in fedora that waits for a key stroke in order to procede. Maybe DCOP. I tested (a while ago on FC8) 2.6.27-0.173.rc0.git11.fc8.i686 (ACPI Corerevision 20080609)and everything was fine. Version 2.6.27-0.254.rc3.fc9.i686 freezes.

Any Ideas? OS or Kernel?
Comment 4 Joshua Covington 2008-08-14 19:05:55 EDT
I patched the 2.6.26.2 kernel with acpi-test-20080609-rc8 from http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/test/2.6.26/acpi-test-20080609-2.6.26-rc8.diff.gz but the problem is still there.

Kernels that work:
2.6.25.14-108.fc9 and previous
2.6.27-0.173.rc0.git11.fc9

Kernels that don't work:
2.6.26.1-9.fc9
2.6.26.2-14.fc9
2.6.27-0.254.rc3.fc9

So there should be something between 0.173.rc0.git11 and 0.254.rc3 that doesn't work for me.

Anyone, any ideas?
Comment 5 Joshua Covington 2008-08-22 12:02:27 EDT
I kept trying the other kernels to see if they hang. This is what I found (from the 2.6.27 series)
up to 2.6.27-0.238.rc2.fc9.i686 everything is fine but with 0.238 I have no display. Just a black screen. I tried removing the noeuvo + drm patch but it didn't help. applyung acpica-20080608 doesn't resolve the problem too.

So i decided to try the 2.6.26.2-14-fc9 with udevdebug - virtually millions of messages were shown on the screen and nothing else.
I changed the wait_for_queue() in /sbin/start_udev to return 0 after local ret=0 and this helped me to overcome the freeze at startup. but lots of devices weren't working after this.

My assumption is that udev isn't initializing something properly, or it is blocked by selinux (see the dmesg-debug-udev) and therefore it waits indefinitely at startup.
Comment 6 Joshua Covington 2008-08-22 12:03:25 EDT
Created attachment 314815 [details]
dmesg-debug-udev
Comment 7 Joshua Covington 2008-08-27 18:17:25 EDT
The udev works fine with the 2.6.25.14-108 kernel. Why shouldn't it do the same with 2.6.26?
I read on phoronix and other forums that the TTM was replaced by GEM in the kernel. At the same time D. Airlie has merged many drm patches in the fedora kernel. And this is the common thing between the 2.6.26.3 kernel and the 2.6.27-0.284.rc4.git6.fc10. With the latest I see "starting udev" and then I got black and white stips on the display. Nothing else can be seen or done.

Therefore I think not the udev but something in the kernel conserning the modesetting on my radeon RS482 is causing the problem.It all started with the kernel update.

Let's see what the drm-devels think.
Comment 8 Fedora Update System 2008-08-31 11:02:21 EDT
kernel-2.6.26.3-27.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-27.fc9
Comment 9 Joshua Covington 2008-09-01 16:17:32 EDT
Created attachment 315492 [details]
linux-2.6-x86-32-amd-c1e-force-timer-broadcast-late.patch

This patch fixes the problem. I tried it with 2.6.26.3-17.fc9 and 2.6.27-0.290.rc5.fc10. Everything is fine. Maybe it hould be integrated in the 2.6.27 branch. The bug is resolved.
Comment 10 Fedora Update System 2008-09-03 12:49:43 EDT
kernel-2.6.26.3-29.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.3-29.fc9
Comment 11 Fedora Update System 2008-09-05 08:19:47 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-09-10 03:07:10 EDT
kernel-2.6.26.3-29.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Brian Millett 2008-09-12 09:38:41 EDT
Dell d820
kernel-2.6.26.3-29.fc9.i686 hangs at "Starting UDEV:"
older kernels work just fine.

What else should I include about system that would help?
Comment 14 LJ 2008-09-17 11:42:22 EDT
kernel-2.6.26.3-29.fc9.i686 hangs after decompression
Comment 15 birger 2008-09-30 20:21:51 EDT
my 2.6.26.3-29 started hanging after i installed vmware server 2. could be a coincidence, but...

Note You need to log in before you can comment on or make changes to this bug.