Bug 458902 - transmission package includes a program which segfaults
transmission package includes a program which segfaults
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 22:28 EDT by Michal Jaegermann
Modified: 2008-09-24 20:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-08-12 22:28:55 EDT
Description of problem:

This package has benc2php.  If you will try to run 'benc2php -h'
or 'benc2php --help' then a response is:

Invalid metadata
Segmentation fault (core dumped)

Actually it looks like that passing as an argument mostly anything,
be that a single '-', or some letter of alphabet, has the same effect
as above.  Without any arguments benc2php prints:

Convert bencoded text to serialized php.
Usage: benc2php bencoded-text

which is slightly better but not a good reason for segfaulting
in other circumstances.  This was checked on an x86_64 machine and only
there.

Version-Release number of selected component (if applicable):
transmission-1.22-1.fc9

How reproducible:
always
Comment 1 Kevin 2008-08-16 21:03:43 EDT
Your synopsis of the problem is accurate. Basically anything that it can not parse throws a segfault error.

No -h tag exists within the code, therefore it treats it as parseable input and seg faults.

I've lowered the priority and severity of this bug, as the application does work - however it should be modified to throw an actual error and not seg fault when inappropriate input is entered.
Comment 2 Denis Leroy 2008-08-24 08:21:34 EDT
Looks like benc2php is gone in version 1.33. Expect an update soon.
Comment 3 Fedora Update System 2008-08-24 10:08:08 EDT
transmission-1.33-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/transmission-1.33-1.fc9
Comment 4 Fedora Update System 2008-09-10 02:49:24 EDT
transmission-1.33-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update transmission'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7546
Comment 5 Fedora Update System 2008-09-24 20:20:54 EDT
transmission-1.33-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.