Bug 458940 - Crashing gnome-terminal
Crashing gnome-terminal
Status: CLOSED DUPLICATE of bug 458544
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-08-13 07:54 EDT by Zdenek Kabelac
Modified: 2008-08-14 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-14 11:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2008-08-13 07:54:47 EDT
Description of problem:

Recently gnome-terminal started to generate a lot of coredumps:

Here are some gdb backtraces:
#0  vte_terminal_extend_selection (terminal=0xd6c560, x=320, y=83, always_grow=0, force=<value optimized out>) at vte.c:6147
#1  0x00007fc9bfee804f in vte_terminal_motion_notify (widget=0x0, event=0xca8010) at vte.c:6632
#2  0x00007fc9bf963a90 in _gtk_marshal_BOOLEAN__BOXED (closure=0x6a0290, return_value=0x7fffca336640, n_param_values=2, 
    param_values=0xcedf50, invocation_hint=0x7fffca336600, marshal_data=0x7fc9bfee7c40) at gtkmarshalers.c:84
#3  0x00007fc9bd90a7fd in IA__g_closure_invoke (closure=0x6a0290, return_value=0x7fffca336640, n_param_values=2, 
    param_values=0xcedf50, invocation_hint=0x7fffca336600) at gclosure.c:767
#4  0x00007fc9bd921264 in signal_emit_unlocked_R (node=0x6a0300, detail=0, instance=0xd6c560, emission_return=0x7fffca336780, 
    instance_and_params=0xcedf50) at gsignal.c:3282
#5  0x00007fc9bd922b58 in IA__g_signal_emit_valist (instance=0xd6c560, signal_id=<value optimized out>, detail=0, 
    var_args=0x7fffca3367e0) at gsignal.c:2987
#6  0x00007fc9bd923213 in IA__g_signal_emit (instance=0xffffffff, signal_id=4294967295, detail=0) at gsignal.c:3034
#7  0x00007fc9bfacee61 in gtk_widget_event_internal (widget=0xd6c560, event=0xca8010) at gtkwidget.c:4745
#8  0x00007fc9bface983 in IA__gtk_widget_event (widget=0xd6c560, event=0xca8010) at gtkwidget.c:4539
#9  0x00007fc9bf961d22 in IA__gtk_propagate_event (widget=0xd6c560, event=0xca8010) at gtkmain.c:2361
#10 0x00007fc9bf9606f0 in IA__gtk_main_do_event (event=0xca8010) at gtkmain.c:1560
#11 0x00007fc9bf387e93 in gdk_event_dispatch (source=0x67dd40, callback=0, user_data=0x0) at gdkevents-x11.c:2365
#12 0x00007fc9bd4528c2 in g_main_dispatch () at gmain.c:2072
#13 IA__g_main_context_dispatch (context=0x67ddc0) at gmain.c:2624
#14 0x00007fc9bd45605d in g_main_context_iterate (context=0x67ddc0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2705
#15 0x00007fc9bd45658d in IA__g_main_loop_run (loop=0x6e6840) at gmain.c:2928
#16 0x00007fc9bf95fe41 in IA__gtk_main () at gtkmain.c:1171
#17 0x0000000000415d75 in g_hash_table_new () at ghash.c:318
#18 0x00007fc9bc4ca566 in __libc_start_main (main=0x415a50 <g_hash_table_new+23616>, argc=1, ubp_av=0x7fffca336d78, 
    init=0x429dc0 <g_hash_table_new+106416>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffca336d68)
    at libc-start.c:220
#19 0x000000000040fe49 in g_hash_table_new () at ghash.c:318
#20 0x00007fffca336d68 in ?? ()
#21 0x000000000000001c in ?? ()
#22 0x0000000000000001 in ?? ()
#23 0x00007fffca33866c in ?? ()
#24 0x0000000000000000 in ?? ()



--------

#0  vte_terminal_extend_selection (terminal=0x15d7ba0, x=370, y=720, always_grow=100, 
    force=<value optimized out>) at vte.c:6178
#1  0x00007fcde38e604f in vte_terminal_motion_notify (widget=0x0, event=0xcd2d00) at vte.c:6632
#2  0x00007fcde3361a90 in _gtk_marshal_BOOLEAN__BOXED (closure=0x6a0290, return_value=0x7fffedd357f0, 
    n_param_values=2, param_values=0x152a070, invocation_hint=0x7fffedd357b0, 
    marshal_data=0x7fcde38e5c40) at gtkmarshalers.c:84
#3  0x00007fcde13087fd in IA__g_closure_invoke (closure=0x6a0290, return_value=0x7fffedd357f0, 
    n_param_values=2, param_values=0x152a070, invocation_hint=0x7fffedd357b0) at gclosure.c:767
#4  0x00007fcde131f264 in signal_emit_unlocked_R (node=0x6a0300, detail=0, instance=0x15d7ba0, 
    emission_return=0x7fffedd35930, instance_and_params=0x152a070) at gsignal.c:3282
#5  0x00007fcde1320b58 in IA__g_signal_emit_valist (instance=0x15d7ba0, signal_id=<value optimized out>, 
    detail=0, var_args=0x7fffedd35990) at gsignal.c:2987
#6  0x00007fcde1321213 in IA__g_signal_emit (instance=0xffffffff, signal_id=0, detail=0)
    at gsignal.c:3034
#7  0x00007fcde34cce61 in gtk_widget_event_internal (widget=0x15d7ba0, event=0xcd2d00)
    at gtkwidget.c:4745
#8  0x00007fcde34cc983 in IA__gtk_widget_event (widget=0x15d7ba0, event=0xcd2d00) at gtkwidget.c:4539
#9  0x00007fcde335fd22 in IA__gtk_propagate_event (widget=0x15d7ba0, event=0xcd2d00) at gtkmain.c:2361
#10 0x00007fcde335e6f0 in IA__gtk_main_do_event (event=0xcd2d00) at gtkmain.c:1560
#11 0x00007fcde2d85e93 in gdk_event_dispatch (source=0x67dd40, callback=0, user_data=0x0)
    at gdkevents-x11.c:2365
#12 0x00007fcde0e508c2 in g_main_dispatch () at gmain.c:2072
#13 IA__g_main_context_dispatch (context=0x67ddc0) at gmain.c:2624
#14 0x00007fcde0e5405d in g_main_context_iterate (context=0x67ddc0, block=1, dispatch=1, 
    self=<value optimized out>) at gmain.c:2705
#15 0x00007fcde0e5458d in IA__g_main_loop_run (loop=0x6e68b0) at gmain.c:2928
#16 0x00007fcde335de41 in IA__gtk_main () at gtkmain.c:1171
#17 0x0000000000415d75 in g_hash_table_new () at ghash.c:318
#18 0x00007fcddfec8566 in __libc_start_main (main=0x415a50 <g_hash_table_new+23616>, argc=1, 
    ubp_av=0x7fffedd35f28, init=0x429dc0 <g_hash_table_new+106416>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffedd35f18) at libc-start.c:220
#19 0x000000000040fe49 in g_hash_table_new () at ghash.c:318
#20 0x00007fffedd35f18 in ?? ()
#21 0x000000000000001c in ?? ()
#22 0x0000000000000001 in ?? ()
#23 0x00007fffedd3766b in ?? ()
#24 0x0000000000000000 in ?? ()

------
#0  vte_terminal_extend_selection (terminal=0xbe8b50, x=1088, y=832, always_grow=32, 
    force=<value optimized out>) at vte.c:6178
#1  0x00007f1083177ae4 in vte_terminal_autoscroll (terminal=0xbe8b50) at vte.c:6521
#2  0x00007f10806da05b in g_timeout_dispatch (source=0xd75680, callback=0, user_data=0x0) at gmain.c:3531
#3  0x00007f10806d98c2 in g_main_dispatch () at gmain.c:2072
#4  IA__g_main_context_dispatch (context=0x67dee0) at gmain.c:2624
#5  0x00007f10806dd05d in g_main_context_iterate (context=0x67dee0, block=1, dispatch=1, 
    self=<value optimized out>) at gmain.c:2705
#6  0x00007f10806dd58d in IA__g_main_loop_run (loop=0x6e6990) at gmain.c:2928
#7  0x00007f1082befe55 in IA__gtk_main () at gtkmain.c:1172
#8  0x0000000000415d75 in g_hash_table_new () at ghash.c:318
#9  0x00007f107f751566 in __libc_start_main (main=0x415a50 <g_hash_table_new+23616>, argc=1, 
    ubp_av=0x7fff8d5c89a8, init=0x429dc0 <g_hash_table_new+106416>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff8d5c8998) at libc-start.c:220
#10 0x000000000040fe49 in g_hash_table_new () at ghash.c:318
#11 0x00007fff8d5c8998 in ?? ()
#12 0x000000000000001c in ?? ()
#13 0x0000000000000001 in ?? ()
#14 0x00007fff8d5c966a in ?? ()
#15 0x0000000000000000 in ?? ()






Version-Release number of selected component (if applicable):
vte-0.17.1-1.fc10.x86_64

How reproducible:
Unsure - but usually gnome-terminal disappear while marking some text areas with mouse.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
stable gnome-terminal 

Additional info:
Comment 1 Behdad Esfahbod 2008-08-14 11:37:52 EDT

*** This bug has been marked as a duplicate of bug 458544 ***

Note You need to log in before you can comment on or make changes to this bug.