Bug 458951 - [sd-IN] Sindhi language is not identified by fontconfig
[sd-IN] Sindhi language is not identified by fontconfig
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 09:38 EDT by Rahul Bhalerao
Modified: 2009-06-02 01:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 01:17:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snd.orth file (1.28 KB, text/plain)
2008-08-13 09:40 EDT, Rahul Bhalerao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17140 None None None Never

  None (edit)
Description Rahul Bhalerao 2008-08-13 09:38:24 EDT
Description of problem:
One of the scripts used for representing Sindhi language is Devanagari. Although the fonts for Devanagari are installed, fontconfig does not recognize them as Sindhi fonts. 
This is because there is no snd.orth file for Sindhi language. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rahul Bhalerao 2008-08-13 09:40:52 EDT
Created attachment 314203 [details]
snd.orth file 

Adding this file to the fc-lang directory in fontcofig source tree solves the problem.
Comment 2 Behdad Esfahbod 2008-08-14 14:29:39 EDT
Upstreamed:
https://bugs.freedesktop.org/show_bug.cgi?id=17140

It will be in F10.
Comment 3 Behdad Esfahbod 2008-08-16 22:23:42 EDT
Shouldn't the tag be "sd"?  Isn't that what's used for the Sindhi locale?
Comment 4 Rahul Bhalerao 2008-08-18 12:47:13 EDT
(In reply to comment #3)
> Shouldn't the tag be "sd"?  Isn't that what's used for the Sindhi locale?

yep, I took the three letter code earlier. Two letter code should be preferred.
Comment 5 Tony Fu 2008-09-09 23:06:48 EDT
requested by Jens Petersen (#27995)
Comment 6 Bug Zapper 2008-11-25 21:45:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Parag Nemade 2009-06-02 01:17:02 EDT
As Sindhi language translations are not in Fedora yet and this is fixed in rawhide(F11), I think we can close this as RAWHIDE instead to wait for backporting current fontconfig release to F10.

Note You need to log in before you can comment on or make changes to this bug.