Bug 459006 - isnull and and isnotnull are missing from boolean chart types
isnull and and isnotnull are missing from boolean chart types
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 14:30 EDT by David Lawrence
Modified: 2013-06-24 00:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-14 11:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add isnull and isnotnull to boolean charts (v1) (2.28 KB, patch)
2008-08-13 14:35 EDT, David Lawrence
nelhawar: review+
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 345194 None None None Never

  None (edit)
Description David Lawrence 2008-08-13 14:30:28 EDT
Description of problem:

Before the bugzilla upgrade, I used to be able to query for bugzilla's 
where:

issuetracker isnotnull

which would give me all of the bugzilla's that had an associated 
issuetracker.

The new interface doesn't seem to support "isnotnull" as a valid value 
for boolean expressions, so my canned queries are *broken* now.
Comment 1 David Lawrence 2008-08-13 14:35:41 EDT
Created attachment 314231 [details]
Patch to add isnull and isnotnull to boolean charts (v1)

Patch that adds support for isnull and isnotnull to the boolean charts section. I have tested it on bz-web2-test and it properly displays bugs with or without issuetrackers attached to them.

Please review

Dave
Comment 2 David Lawrence 2008-08-13 15:31:54 EDT
From: Eric Sammons

Dave,

thank you, this is exactly what I was looking for.  I do have one more question, is there anyway to negate private bz (so that only public are returned) and how does one tell if a bz is embargoed and if there is a flag or something to key off of can those be excluded along with the private BZs?

thank you!

---

Testing to see if fix for this bug will work for this request as well since it should be similar.

Dave
Comment 3 Todd Sanders 2008-08-14 09:37:43 EDT
Dave,

Thanks!  I tested my queries against bz-web2-test, and all appears to be working.  When can we get this change committed to production?

-Todd
Comment 4 Noura El hawary 2008-08-14 10:30:19 EDT
Comment on attachment 314231 [details]
Patch to add isnull and isnotnull to boolean charts (v1)

Hey Dave,,

Patch looks good and works fine , just a little nit pik,

>+  { name => "matches", description => "matches" },
>+  { name => "isnull", description => "Is Null" },
>+  { name => "isnotnull", description => "Is Not Null" }] %]

shall we make Is Null and Is Not Null all small letters to be consistent with other boolean chart options.

Noura
Comment 5 David Lawrence 2008-08-14 11:56:37 EDT
Thanks Noura. I changed the descriptions to lower case before I checked in.
Will be in the next update (today).

Dave
Comment 6 Frédéric Buclin 2008-08-21 20:17:16 EDT
https://bugzilla.mozilla.org/show_bug.cgi?id=345194 is our upstream bug related to this issue. This patch should go away when the upstream bug is fixed (or be proposed there).

Note You need to log in before you can comment on or make changes to this bug.