Bug 459036 - ofed issues
ofed issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat HPC Solution
Classification: Red Hat
Component: kit-rhel-ofed (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: OCS Support
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 16:39 EDT by Rafael Garabato
Modified: 2008-09-10 18:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.1rc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 18:44:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ofed error screen caption (68.72 KB, image/jpeg)
2008-08-13 16:39 EDT, Rafael Garabato
no flags Details

  None (edit)
Description Rafael Garabato 2008-08-13 16:39:24 EDT
Created attachment 314259 [details]
Ofed error screen caption

Description of problem:
After adding the Ofed kit with the script /opt/kusu/sbin/install-, when the kit is added to the installer node with ngedit some dependency issues appeared that should have been solved by yum.

If the dependencies are added, the same error occurs as if the package wasn't installed.

After the installation says done, the component package cannot be found:
[root@redhathpc /]# rpm -qa | grep -i ofed
ocs-kit-rhel-ofed-1.0-2
kit-rhel-ofed-1.2.5-4

And the ofed_info command is not present.

Also, the ofed kit comes with the following packages from what I could gather:
dapl
dapl-utils
ibutils
ibutils-libs
libibcm
libibcommon
libibmad
libibumad
libibverbs
libibverbs-utils
libipathverbs
libmthca
librdmacm
librdmacm-utils
libsdp
openib
openib-diags
openib-mstflint
openib-perftest
openib-srptools
openib-tvflash
opensm
opensm-libs
dapl-devel
libibcm-devel
libibcommon-devel
libibmad-devel
libibumad-devel
libibverbs-devel
libmthca-devel
librdmacm-devel
ibutils-devel
libipathverbs-devel
opensm-devel

At the end only the following packages appear installed:
libibcommon-1.0.8-1.el5
libibmad-1.1.6-1.el5
libibumad-1.1.7-1.el5
libibverbs-1.1.1-9.el5
libipathverbs-1.1-10.el5
libmthca-1.0.4-9.el5
librdmacm-1.0.7-1.el5
opensm-libs-3.1.8-1.el5

Which are less than the rpms that comes with the Ofed kit available in POCS 5:
libnes-devel-static = 0.5
libcxgb3-devel = 1.1.4
opensm-devel = 3.1.10
libibmad-devel = 1.1.6
kernel-ib-devel = 1.3
libsdp-devel = 1.1.99
libibcommon-devel = 1.0.8
libibcm-devel = 1.0.2
libmlx4-devel-static = 1.0
libibverbs-devel = 1.1.1
libmthca-devel-static = 1.0.4
librdmacm-devel = 1.0.6
dapl-devel-static = 1.2.5
libibumad-devel = 1.1.7
dapl-devel = 1.2.5
libipathverbs-devel = 1.1
libibverbs-devel-static = 1.1.1
dapl = 1.2.5
dapl-utils = 1.2.5
ibsim = 0.4
ibutils = 1.2
ibvexdmtools = 0.0.1
infiniband-diags = 1.3.6
iscsi-initiator-utils = 2.0
kernel-ib = 1.3
libcxgb3 = 1.1.4
libibcm = 1.0.2
libibcommon = 1.0.8
libibcommon-static = 1.0.8
libibmad = 1.1.6
libibmad-static = 1.1.6
libibumad = 1.1.7
libibumad-static = 1.1.7
libibverbs = 1.1.1
libibverbs-utils = 1.1.1
libipathverbs = 1.1
libmlx4 = 1.0
libmthca = 1.0.4
libnes = 0.5
librdmacm = 1.0.6
librdmacm-utils = 1.0.6
libsdp = 1.1.99
mpi-selector = 1.0.0
mstflint = 1.3
ofed-docs = 1.3
ofed-scripts = 1.3
ofed-src = 1.3
open-iscsi = 2.0
opensm = 3.1.10
opensm-libs = 3.1.10
opensm-static = 3.1.10
perftest = 1.2
qlvnictools = 0.0.1
qperf = 0.4.0
sdpnetstat = 1.60
srptools = 0.0.4
tvflash = 0.9.0


Version-Release number of selected component (if applicable):
Red Hat 5.2



How reproducible:


Steps to Reproduce:
1.Execute ngedit
2.Add the ofed components (both devel and main) to the installer node
3.Continue until the repositories are updated.
  
Actual results:
See attachment

Expected results:


Additional info:
Comment 1 Keve Gabbert 2008-08-22 11:45:46 EDT
Is anyone looking at this BZ?  I'm not seeing any updates from ocs2@platform.com.  Do we need to change from "new" to "assigned" and actually assign it to a person?
Comment 2 Doug Ledford 2008-08-22 12:48:54 EDT
My understanding was that Tim Burke was planning on organizing a time for myself and other people to have a concall to go over this stuff.
Comment 3 Rafael Garabato 2008-08-26 14:23:08 EDT
I found one of the problems.

The packages that belong to the kit are not downloaded by the kit installer.

I edited the file /opt/kusu/sbin/install-kit-rhel-ofed and substitute:

KITPKGS="kit-rhel-ofed
component-RHEL-OFED
component-RHEL-OFED-devel"

with:
KITPKGS="kit-rhel-ofed
component-RHEL-OFED
component-RHEL-OFED-devel
dapl
dapl-utils
ibutils
ibutils-libs
libibcm
libibcommon
libibmad
libibumad
libibverbs
libibverbs-utils
libipathverbs
libmthca
librdmacm
librdmacm-utils
libsdp
openib
openib-diags
openib-mstflint
openib-perftest
openib-srptools
openib-tvflash
opensm
opensm-libs
dapl-devel
libibcm-devel
libibcommon-devel
libibmad-devel
libibumad-devel
libibverbs-devel
libmthca-devel
librdmacm-devel
ibutils-devel
libipathverbs-devel
opensm-devel"


This list of packages was obtained with the command:
rpm -qp --requires component-RHEL-OFED-1.2.5-2.noarch.rpm
rpm -qp --requires component-RHEL-OFED-devel-1.2.5-2.noarch.rpm


However, when adding the components to the installer node it is still failing:

     â cfmsync reported successful return. Please inspect its output:   â â
     â Error: Missing Dependency: libosmcomp.so.1(OSMCOMP_1.1)(64bit)   â® â
     â is needed by package openib-diags                                â â
     â Error: Missing Dependency: libosmcomp.so.1()(64bit) is needed    â â
     â by package openib-diags                                          â â
     â Error: Missing Dependency: libipathverbs = 1.1-6.el5_1.1 is      â â
     â needed by package libipathverbs-devel                            â â
     â Error: Missing Dependency: libmthca = 1.0.4-6.el5_1.1 is         â â
     â needed by package libmthca-devel                                 â â
     â Done                                                             â â
     â Running plugin:  /opt/kusu/lib/plugins/cfmsync/getent-data.sh    â â
     â Updating installer(s)
Comment 4 Rafael Garabato 2008-08-26 14:37:20 EDT
This later problem could be related to the order of the packages that are required by RHEL-OFED.

As it can be seen below, openib-diags is before opensm-libs which should have missing library libosmcomp.so.1

[root@rhhpcml noarch]# rpm -qp --requires component-RHEL-OFED-1.2.5-2.noarch.rpm
dapl
dapl-utils
ibutils
ibutils-libs
libibcm
libibcommon
libibmad
libibumad
libibverbs
libibverbs-utils
libipathverbs
libmthca
librdmacm
librdmacm-utils
libsdp
openib
openib-diags
openib-mstflint
openib-perftest
openib-srptools
openib-tvflash
opensm
opensm-libs


Could this be the reason? Is there any way to workaround this?
Comment 5 Rafael Garabato 2008-08-26 16:56:40 EDT
My theory about the order of packages was incorrect (comment 4). I tried installing the packages with yum and in debug mode and I got the log at the end. The problem is that openib-diags request an older version of libosmcomp.so, which is libosmcomp.so.1. But opensm-diags provides a newer one libosmcomp.so.2.
The package openib-diags must be updated.


---> Package openib-diags.x86_64 0:1.2.7-6.el5_1.1 set to be updated
Checking deps for openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libc.so.6()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('openib', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('/usr/bin/perl', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('perl', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libopensm.so.1(OPENSM_1.5)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libopensm.so.1()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('perl(IBswcountlimits)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('perl(lib)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libosmvendor.so.2()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libosmcomp.so.1(OSMCOMP_1.1)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libosmcomp.so.1()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('perl(Getopt::Std)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libibmad.so.1()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libibmad.so.1(IBMAD_1.3)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libibcommon.so.1()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libibcommon.so.1(IBCOMMON_1.0)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('perl(strict)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libosmvendor.so.2(OSMVENDOR_2.0)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libibumad.so.1(IBUMAD_1.0)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libc.so.6(GLIBC_2.3)(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
looking for ('libibumad.so.1()(64bit)', None, (None, None, None)) as a requirement of openib-diags.x86_64 0-1.2.7-6.el5_1.1 - u
openib-diags requires: libosmcomp.so.1(OSMCOMP_1.1)(64bit)
--> Processing Dependency: libosmcomp.so.1(OSMCOMP_1.1)(64bit) for package: openib-diags
Searching pkgSack for dep: libosmcomp.so.1(OSMCOMP_1.1)(64bit)
skipping reposetup, pkgsack exists
Potential match for libosmcomp.so.1(OSMCOMP_1.1)(64bit) from opensm-libs - 2.0.0-5.el5.x86_64
Matched opensm-libs - 2.0.0-5.el5.x86_64 to require for libosmcomp.so.1(OSMCOMP_1.1)(64bit)
Potential match for libosmcomp.so.1(OSMCOMP_1.1)(64bit) from opensm-libs - 3.0.3-6.el5.x86_64
Matched opensm-libs - 3.0.3-6.el5.x86_64 to require for libosmcomp.so.1(OSMCOMP_1.1)(64bit)
Potential match for libosmcomp.so.1(OSMCOMP_1.1)(64bit) from opensm-libs - 3.0.3-6.el5_1.1.x86_64
Matched opensm-libs - 3.0.3-6.el5_1.1.x86_64 to require for libosmcomp.so.1(OSMCOMP_1.1)(64bit)
Potential resolving package opensm-libs - 2.0.0-5.el5.x86_64 has newer instance in ts.
Potential resolving package opensm-libs - 3.0.3-6.el5.x86_64 has newer instance in ts.
Potential resolving package opensm-libs - 3.0.3-6.el5_1.1.x86_64 has newer instance in ts.
openib-diags requires: libosmcomp.so.1()(64bit)
--> Processing Dependency: libosmcomp.so.1()(64bit) for package: openib-diags
Searching pkgSack for dep: libosmcomp.so.1()(64bit)
skipping reposetup, pkgsack exists
Potential match for libosmcomp.so.1()(64bit) from opensm-libs - 2.0.0-5.el5.x86_64
Matched opensm-libs - 2.0.0-5.el5.x86_64 to require for libosmcomp.so.1()(64bit)
Potential match for libosmcomp.so.1()(64bit) from opensm-libs - 3.0.3-6.el5.x86_64
Matched opensm-libs - 3.0.3-6.el5.x86_64 to require for libosmcomp.so.1()(64bit)
Potential match for libosmcomp.so.1()(64bit) from opensm-libs - 3.0.3-6.el5_1.1.x86_64
Matched opensm-libs - 3.0.3-6.el5_1.1.x86_64 to require for libosmcomp.so.1()(64bit)
Potential resolving package opensm-libs - 2.0.0-5.el5.x86_64 has newer instance in ts.
Potential resolving package opensm-libs - 3.0.3-6.el5.x86_64 has newer instance in ts.
Potential resolving package opensm-libs - 3.0.3-6.el5_1.1.x86_64 has newer instance in ts.
Comment 6 Doug Ledford 2008-08-26 17:20:49 EDT
openib-diags is an old package that was replaced by infiniband-diags
libipathverbs-devel is an old package replaced by libipathverbs-static
libmthca-devel is an old package replaced by libmthca-static


The fact that you are included outdated packages in your list is causing them to create unsolvable dependency issues.  There are actually about 5 other package renames that you need to be aware of too.

Be aware of the fact that we do *NOT* have exactly the same package list as *ANY* version of OFED, and to assume that we would, given that we include the kernel portion in our own kernel package while they ship kernel modules in a kernel-ib package and that they ship things like iscsi-initiator-utils that we already have our own version of, would be silly.

For a definitive list of RHEL release packages, you can look into the RHEL RHN channel or you can look into the OpenIB errata for RHEL5.2.  Either of those lists the files included as part of the RHEL5.2 OpenIB errata.  There is a separate OpenMPI errata for RHEL5.2, so you can look there for the definitive OpenMPI package list.
Comment 7 Mark Black 2008-08-26 17:46:04 EDT
The component-* rpms have to change to reflect the new names of the packages.  We are still working out what the names of the packages are.  The erratas only mention 2 changed packages (RHBA-2008:0432), so we will have to look for the others by looking at the packages in RHEL 5.2.

We (Platform) are in the process of updating this kit to work with RH HPC.
Once it has been tested a new SRPM will be provided to Red Hat, and the affected package(s) placed on the channel.
Comment 8 Mark Black 2008-08-29 15:21:12 EDT
Updated SRPMs have been sent to Red Hat.  It addresses the package dependencies.
Comment 9 Rafael Garabato 2008-09-03 09:12:21 EDT
Once the new packages are added to the Yum repository, Can anyone from Red Hat update the "Fixed in Version" field? Just to be sure I am using the right package version.
Comment 10 Nils Philippsen 2008-09-03 10:27:44 EDT
I'd like Platform to do this -- they're assigned to the bug and will check that the packages they submitted for building are available via FTP/RHN anyway.
Comment 11 Rafael Garabato 2008-09-05 12:43:02 EDT
Any update?. Is there an estimate date of when will this be available in RHN?
Comment 12 Rafael Garabato 2008-09-09 09:13:25 EDT
Please, I would like to have an update on this issue from either someone from Red Hat Or Platform. was this solved?
Comment 13 OCS Support 2008-09-10 17:06:07 EDT
The fix in the Beta channel has been verified.  It on longer tries to install 1.2.5 OFED.  The fix appears in kit-rhel-ofed-1.3-2
Comment 14 Daniel Riek 2008-09-10 18:44:33 EDT
Verified in test installation.

Note You need to log in before you can comment on or make changes to this bug.