Bug 459041 - update dmidecode from 2.2 to 2.9, the latest version
Summary: update dmidecode from 2.2 to 2.9, the latest version
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils
Version: 4.8
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: 4.8
Assignee: Jarod Wilson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature, Rebase, Reopened
: 459180 (view as bug list)
Depends On:
Blocks: AMD4.8 RHEL4u8_relnotes
TreeView+ depends on / blocked
 
Reported: 2008-08-13 21:21 UTC by Jim
Modified: 2018-10-20 02:25 UTC (History)
8 users (show)

(edit)
dmidecode gives information about BIOSes and motherboard revisions. The version of kernel-utils supplied with this advisory updates dmidecode from version 2.2 to version 2.9. This version identifies newer processors, PCI-express slots and devices, and blade chassis. It also offers enhanced support for the SMBIOS v2.6 specification.
Clone Of:
(edit)
Last Closed: 2009-05-18 20:09:59 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0966 normal SHIPPED_LIVE kernel-utils bug fix and enhancement update 2009-05-18 13:33:02 UTC

Description Jim 2008-08-13 21:21:43 UTC
Red Hat 4.7 ships with dmidecode 2.2 which does not have entries for the type of PCI-E slots used in HP DL380G5's. The PCI-E slots will show "<OUT OF SPEC>" as their type. This problem is fixed by updating to dmidecode 2.9 which also adheres to the latest SMBIOS specification.

Comment 1 Jarod Wilson 2008-08-14 03:28:47 UTC
Reassigning to sub-component owner.

Comment 8 Jarod Wilson 2008-08-21 13:41:47 UTC
*** Bug 459180 has been marked as a duplicate of this bug. ***

Comment 10 RHEL Product and Program Management 2008-09-24 20:25:47 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 12 Jarod Wilson 2008-10-03 21:51:41 UTC

*** This bug has been marked as a duplicate of bug 453642 ***

Comment 13 Jarod Wilson 2008-10-07 19:34:37 UTC
Aiee. I just realized I marked a dmidecode bug as a duplicate of a microcode bug. Definitley NOT the case. Whoops. Reopening this one.

Comment 20 Jarod Wilson 2009-01-08 14:36:29 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The update from dmidecode 2.2 to version 2.9 brings a host of improvements in the realm of identifying the latest processors on the market, identifying PCI-express slots and devices, identifying blade chassis, and brings enhanced support for the SMBIOS v2.6 specification.

Comment 21 Ruediger Landmann 2009-01-14 03:19:56 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-The update from dmidecode 2.2 to version 2.9 brings a host of improvements in the realm of identifying the latest processors on the market, identifying PCI-express slots and devices, identifying blade chassis, and brings enhanced support for the SMBIOS v2.6 specification.+* dmidecode gives information about BIOSes and motherboard revisions. The version of kernel-utils supplied with this advisory updates dmidecode from version 2.2 to version 2.9. This version identifies newer processors, PCI-express slots and devices, and blade chassis. It also offers enhanced support for the SMBIOS v2.6 specification.

Comment 23 Ryan Lerch 2009-01-22 02:02:18 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-* dmidecode gives information about BIOSes and motherboard revisions. The version of kernel-utils supplied with this advisory updates dmidecode from version 2.2 to version 2.9. This version identifies newer processors, PCI-express slots and devices, and blade chassis. It also offers enhanced support for the SMBIOS v2.6 specification.+dmidecode gives information about BIOSes and motherboard revisions. The version of kernel-utils supplied with this advisory updates dmidecode from version 2.2 to version 2.9. This version identifies newer processors, PCI-express slots and devices, and blade chassis. It also offers enhanced support for the SMBIOS v2.6 specification.

Comment 30 errata-xmlrpc 2009-05-18 20:09:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0966.html


Note You need to log in before you can comment on or make changes to this bug.