Bug 459055 - Upper left corner does not work for triggering circle scroll
Upper left corner does not work for triggering circle scroll
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 22:33 EDT by Jesse Keating
Modified: 2013-01-09 22:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 12:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from synclient (11.95 KB, text/plain)
2008-08-13 22:33 EDT, Jesse Keating
no flags Details
xorg log (55.32 KB, text/plain)
2008-08-13 22:34 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2008-08-13 22:33:32 EDT
Created attachment 314275 [details]
output from synclient

When I updated to rawhide (and xorg-x11-drv-synaptics which doesn't have a bz component yet) I lost the ability to use the upper left corner to trigger circle scroll.  All other triggers work.

Attached is a text file holding synclient -l  as well as synclient -m 5  and putting my finger in the upper left corner.

I'll also attach xorg.0.log
Comment 1 Jesse Keating 2008-08-13 22:34:51 EDT
Created attachment 314276 [details]
xorg log
Comment 2 Peter Hutterer 2008-08-14 01:29:39 EDT
just tried it here and it works fine.

From the log:
(II) Synaptics: x-axis range 1472 - 5472
(II) Synaptics: y-axis range 1408 - 4448

From synclient:
LeftEdge                = 1472
RightEdge               = 5472
TopEdge                 = 1408
BottomEdge              = 4448

The synaptics driver detects edges if coordinates exceed the given value (e.g. if x > RightEdge -> mark as right edge). 
In your case, the value cannot exceed, hence edge detection is broken. Can you please try after running
synclient LeftEdge=1550
synclient TopEdge=1500

This should enable it. If not, something is seriously broken. I'm also surprised that the other edges work since the edge detection conditions should never be true.

That said, the driver could probably be smarter and enable the edges inwards from the maximum range. I'll get a fix for that upstream.
Comment 3 Jesse Keating 2008-08-14 08:11:13 EDT
After setting the edges as suggested it still doesn't work for top left corner.
Comment 4 Peter Hutterer 2008-08-14 09:53:46 EDT
Moving to right component.
Comment 5 Peter Hutterer 2008-08-17 20:52:52 EDT
I need to ask you for testing with
synclient LeftEdge=1650
synclient TopEdge=1600

I think the values I gave you last time were too close to the edge. Looking at your synclient output these should be better now. If they don't work, please try something really high (3000, 2500). This should transform half your touchpad into edges.
Comment 6 Jesse Keating 2008-09-03 12:57:19 EDT
huh, for some reason, the corner started working at some point.  I just tried setting it to that top left corner without passing your edge options, just to verify that the problem still happened, and it does!  So, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.