This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 459094 - Password prompt for encrypted devices doesn't show which device is about to decrypt
Password prompt for encrypted devices doesn't show which device is about to d...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-08-14 09:06 EDT by Alexander Todorov
Modified: 2008-08-29 16:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-29 16:50:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot of the boot screen (1.32 KB, image/png)
2008-08-14 09:07 EDT, Alexander Todorov
no flags Details
passphrase prompt in visual mode (635.58 KB, image/png)
2008-08-14 10:28 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-08-14 09:06:17 EDT
Description of problem:
When booting for the first time and having encrypted partitions plymouth is showing the string Password: which 
- might look strange to a newbie, making them think this is the login password
- is not showing which device is the password meant to decrypt

Version-Release number of selected component (if applicable):
f10-alpha

How reproducible:
Alwaya

Steps to Reproduce:
1. Create an encrypted partition(s) during install
2. Boot the system

  
Actual results:
Only the string "Password:" is shown on a black background

Expected results:
Enter the LUKS passphrase for /dev/mapper/luks-VolGroup00 :

Additional info:
This can be considered a regression from Fedora 9 since this prompt is properly fixed there. 

Additional improvement can be to show the actual mount point instead of the underlying device, i.e. 
Enter password for / (/home, swap, etc):
Comment 1 Alexander Todorov 2008-08-14 09:07:00 EDT
Created attachment 314314 [details]
screen shot of the boot screen
Comment 2 Alexander Todorov 2008-08-14 10:28:59 EDT
Created attachment 314320 [details]
passphrase prompt in visual mode

The previous attachment was in text mode of plymouth and this one is in visual mode. It's even worse as it only displays an icon and a text entry field with no explanation to what should be entered.
Comment 3 Ray Strode [halfline] 2008-08-14 10:52:27 EDT
So this was discussed a while back and we came to a few conclusions:

1) we really need to give a description of what partition is getting unlocked when it's ambiguous

2) it's hard to show text in the initrd. No translations, no font rendering libraries (in the case of graphical boot), etc

We should be able to satisfy 2) by loading the font rendering libraries after / is mounted, and just have a generic prompt for the first password (/)

This is on the TODO list at the http://wiki.fedoraproject.org/wiki/Features/BetterStartup

Right now, we don't do it right.
Comment 4 Ray Strode [halfline] 2008-08-27 16:28:10 EDT
So plymouth now supports, e.g.,

plymouth ask-for-password --prompt "/opt is password protected"

(or more likely something like:

format=$(gettext --domain=init-scripts "%s is password protected")
prompt=$(printf $format $mount_point)

plymouth ask-for-password --prompt $prompt --command "cryptsetup luksOpen ...")

need to do the rc.sysinit side of things now
Comment 5 Ray Strode [halfline] 2008-08-29 16:50:54 EDT
i've posted a patch for the rc.sysinit side of things at bug 460702

Note You need to log in before you can comment on or make changes to this bug.