Bug 45911 - No module for Davicom DM9102 (dmfe.o) in kernel-2.4.3-12 errata package.
No module for Davicom DM9102 (dmfe.o) in kernel-2.4.3-12 errata package.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 16:31 EDT by Chris Kloiber
Modified: 2013-07-02 22:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 10:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2001-06-25 16:31:36 EDT
Description of Problem:

Many users of seawolf-list are complaining that the kernel-2.4.3-12 errata
does not contain a dmfe.o module for the Davicom DM9102 network adapter. I
looked for it on my updated system and could not find it either.
Comment 1 Arjan van de Ven 2001-06-25 16:33:29 EDT
The driver isn't their because it used floating point in the kernel.
It couldn't have worked reliably before......
Comment 2 Mike Vanecek 2001-06-26 10:22:50 EDT
Strange, it was included with the RH 7.1 distribution I purchased and 
installed. As far as I know it worked without any problems. The errata source 
includes dmfe.c. If this source has a problem, then should not RH fix it so 
that it does work with their errata? My system worked out of the box. I use 
up2date to update my system and now it does not work. The floating point 
comment hardly provides any solution to getting the errata to work. 

I have downloaded DM9102_linux24x_v136.zip from www.davicom8.com, compiled the 
source, and insmod it. With the exception of a 

Jun 24 13:46:13 www depmod: depmod:  
Jun 24 13:46:13 www depmod: *** Unresolved symbols in
/lib/modules/2.4.3-12/kernel/drivers/net/dmfe.o 
Jun 24 13:46:13 www rc.sysinit: Finding module dependencies:  succeeded 

error, it appears to be working. Have not seen this error on subsequent 
reboots, however, I disabled nfs, rpc, etch. 

I plan on compiling the source provided with the errata to see if I get the 
same results.


Comment 3 Martin Lichtin 2001-06-26 14:59:05 EDT
Can someone make the dmfe.0 for 2.4.3-12 available asap?
I need it urgently. How can you just remove it?
I understand the floating point issue in kernel modules, but after all,
it was running just fine.
Comment 4 Chris Kloiber 2001-06-26 20:30:28 EDT
I have made some UNUPPORTED rpms available on my personal web site:

http://ckloiber.mine.nu

There is no SMP fix in these rpms, just that the module was compiled.
So when it breaks- you own both pieces.
Comment 5 Brian Thompson 2002-03-31 12:17:29 EST
well, you might want to fix this problem...dell is now shipping their 
dimension 8200's with CNet Davicom Pro200WL Ethernet Adaptors (i'm running 
skipjack and it still hasn't been fixed)

Note You need to log in before you can comment on or make changes to this bug.