Bug 459119 - Patch needed from upstream to handle NotificationClosed reason
Patch needed from upstream to handle NotificationClosed reason
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-08-14 10:57 EDT by Tim Waugh
Modified: 2008-08-23 21:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 21:31:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
libnotify-closed-reason.patch (from changeset 3005) (4.66 KB, patch)
2008-08-14 10:57 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2008-08-14 10:57:34 EDT
Created attachment 314323 [details]
libnotify-closed-reason.patch (from changeset 3005)

Description of problem:
The 'closed' signal now carries an extra parameter, and we need to apply a patch from upstream to handle that.

Version-Release number of selected component (if applicable):
notification-daemon-0.3.7.90-1.svn3009.fc10.x86_64
libnotify-0.4.4-11.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Try this:

#!/usr/bin/env python
import gobject
import pynotify

def closed_cb(n, reason=None):
	print "closed"

if __name__ == '__main__':
        pynotify.init ("foo")
        loop = gobject.MainLoop ()
        n = pynotify.Notification("title", "text")
        n.set_timeout (pynotify.EXPIRES_NEVER)
        n.connect ("closed", closed_cb)
        n.show()
        loop.run ()

2.Close the notification
  
Actual results:
No output

Expected results:
"closed"

This breaks system-config-printer's printer event notifications.
Comment 1 Matthias Clasen 2008-08-14 16:05:59 EDT
Let me make sure I understand that. 

Upstream changed the api between the daemon and the client-side ?

But there have not been any releases (daemon or client-side) with the new api, so how exactly does this break s-c-printer ?

Or is this a problem where Ubuntu ships api-changing patches ?

The best solution would certainly be for upstream to release new versions that have the latest api...
Comment 2 Tim Waugh 2008-08-14 17:00:39 EDT
(In reply to comment #1)
> Upstream changed the api between the daemon and the client-side ?

Unfortunately so, but apparently in order to bring it in line with the freedesktop spec.

> But there have not been any releases (daemon or client-side) with the new api,
> so how exactly does this break s-c-printer ?

Fedora devel currently has a notification-daemon package (0.3.7.90-1.svn3009) that uses the new API, which of course breaks because libnotify is still using the old API.

> Or is this a problem where Ubuntu ships api-changing patches ?

No, nothing to do with Ubuntu.

> The best solution would certainly be for upstream to release new versions that
> have the latest api...

Or we could stick to released versions ourselves.. :-)

Reverting to notification-daemon-0.3.7 would also fix this.
Comment 3 Matthias Clasen 2008-08-14 17:39:00 EDT
Ah, ok. In that case, why don't you go ahead and put that patch into rawhide ?
Comment 4 Matthias Clasen 2008-08-23 21:31:55 EDT
Built in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.