Bug 459158 - multipath needs libaio in early userspace, can it be moved from /usr/lib to /lib?
multipath needs libaio in early userspace, can it be moved from /usr/lib to /...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libaio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 15:10 EDT by Ben Marzinski
Modified: 2008-09-15 11:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 11:47:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2008-08-14 15:10:43 EDT
Description of problem:
As mentioned in bz #457589, multipath is failing on bootup because it links against libaio, and it can get called before /usr is mounted.

If it's possible, moving libaio to /lib would fix this problem. Otherwise, there will need to be a multipath binary that is statically linked to libaio.
Comment 1 Jeff Moyer 2008-08-26 08:26:30 EDT
I don't see a reason we can't do this.  I'll put something together and see if anyone pukes on it.
Comment 2 Jeff Moyer 2008-09-03 16:51:54 EDT
I just kicked off a build of libaio-0.3.107-4.fc10.  Do you have a way of testing that package before it is included in the composition?
Comment 3 Jeff Moyer 2008-09-15 11:47:36 EDT
Well, this made it into the tree without testing (aside from my own).  I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.