Bug 459192 - http won't start because mod_fcgid can't create share memory
http won't start because mod_fcgid can't create share memory
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.2
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 16:51 EDT by Philip Goisman
Modified: 2008-08-15 16:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-15 06:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Goisman 2008-08-14 16:51:19 EDT
Description of problem:
apache server won't start due to error displayed in 
/var/log/httpd/error_log:

[emerg] (17)File exists: mod_fcgid: Can't create share memory for size %zu byte

Version-Release number of selected component (if applicable):

httpd-2.2.3-11.el5_1.3

How reproducible:
Start httpd and see error above in log.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I have a work around this problem.  I commented out all the
command lines in /etc/httpd/conf.d/fcgid.conf.  The apache
server then starts and works as expected.
Comment 1 Joe Orton 2008-08-15 06:14:13 EDT
Thanks for contacting us.  This is likely to be a bug in mod_fcgid, but that module is not distributed in Red Hat Enterprise Linux; please contact the upstream developers for further help if you are compiling from source.
Comment 2 Philip Goisman 2008-08-15 16:44:25 EDT
Thanks for pointing me to mod_fcgid.  Since I used RH EL5 rpms, I just
assumed RH was responsible.  The version of mod_fcgid I have is 
mod_fcgid-2.2-4.el5 and the httpd rpms are httpd-2.2.3-11.el5_1.3 and
httpd-manual-2.2.3-11.el5_1.3.  I'm not sure who to direct this bug to now.
Any suggestions?

Note You need to log in before you can comment on or make changes to this bug.