This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 459225 - networkmanager doesn't handle static routes properly
networkmanager doesn't handle static routes properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 03:23 EDT by Craig Schlenter
Modified: 2008-08-19 01:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 01:03:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Schlenter 2008-08-15 03:23:02 EDT
Description of problem:

nm-tool lists static routes correctly as entered in nm-connection-editor but the actual routes are added with a gateway of 0.0.0.0 rather than the gateway specified. This is for a wired interface btw. but it probably doesn't matter.

Version-Release number of selected component (if applicable):

NetworkManager-glib-0.7.0-0.9.4.svn3675.fc9.i386
NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386
NetworkManager-gnome-0.7.0-0.9.4.svn3675.fc9.i386

How reproducible:

Add some static routes in nm-connection-editor. Check that they are correct with nm-tool. Then run /sbin/route and you'll see the gateway entry is wrong.
  
Actual results:

0.0.0.0 for gateway

Expected results:

Correct gateway IP in route
Comment 1 Dan Williams 2008-08-15 12:05:33 EDT
Can you try svn3930 from f9-updates-testing?  That will (a) add a route to the gateway specified via the interface, and (b) add the static route you specify via that gateway.
Comment 2 Craig Schlenter 2008-08-18 00:41:16 EDT
Hi Dan

Thanks for the quick response. Do you have a url handy where I can grab that from please? All the normal methods (yum, directly hitting downloads.fedora and looking in koji which seems to be down) have have failed. I'm guessing this is still part of the 'infrastructure issues' sitation...

Thanks!
Comment 4 Craig Schlenter 2008-08-19 01:03:08 EDT
Seems to work now ... Yay! Thank you.

I've changed the status to CLOSED/ERRATA ... hope that's right.

Note You need to log in before you can comment on or make changes to this bug.